zenking
Hot Shot
Hot Shot

VMware Tools won't upgrade on some VMs

Jump to solution

I have around 20 Windows 2016 Server VMs running on vSphere 6.7. I've upgraded all of the hosts to the latest build (15160138). I'm in the process of upgrading VMware Tools from version 10.3 to 11. Most of the VMs are upgrading without a problem, but a few of them are not upgrading or giving me an error message. On each of these, the upgrade starts and then shows a status of Completed in about 5 seconds, but the version still shows 10.3 and the "Upgrade Available" message is still displayed. The host itself doesn't seem to be the problem because one host has a VM that upgraded and another that won't.

Any ideas?

VMWare Environment: vSphere 7.0, EQ PS6210 SANs, Dell R730 Hosts, dedicated Dell switches w/ separate vlans for vmotion and iscsi.
Tags (1)
0 Kudos
1 Solution

Accepted Solutions
zenking
Hot Shot
Hot Shot

There is no error message. Last week, I had set all of the VMs to upgrade on restart, including these VMs.

A few minutes ago, I ran the interactive upgrade and then ran setup.exe on the mounted vmware tools cd. It rebooted and upgraded, so I guess that will be the answer for any other VMs that won't run the automatic upgrade.

Thanks for your help.

VMWare Environment: vSphere 7.0, EQ PS6210 SANs, Dell R730 Hosts, dedicated Dell switches w/ separate vlans for vmotion and iscsi.

View solution in original post

0 Kudos
3 Replies
Alex_Romeo
Leadership
Leadership

Hi,

1-  error message do you receive?

2- have you tried to restart and install the vmware tools again?

3- in the "change settings" of vm, it is possible to set the installation of the vmware tools when vm is restarted, try to set that setting and restart the vm.

ARomeo

Blog: https://www.aleadmin.it/
0 Kudos
zenking
Hot Shot
Hot Shot

There is no error message. Last week, I had set all of the VMs to upgrade on restart, including these VMs.

A few minutes ago, I ran the interactive upgrade and then ran setup.exe on the mounted vmware tools cd. It rebooted and upgraded, so I guess that will be the answer for any other VMs that won't run the automatic upgrade.

Thanks for your help.

VMWare Environment: vSphere 7.0, EQ PS6210 SANs, Dell R730 Hosts, dedicated Dell switches w/ separate vlans for vmotion and iscsi.
0 Kudos
Alex_Romeo
Leadership
Leadership

very well

Blog: https://www.aleadmin.it/
0 Kudos