VMware Cloud Community

Unable to use Windows 7 32-bit VM on VMware ESXi 7.0.3 build 19193900

I recently tried to import/move a Windows 7 32-bit VM from MS Hyper-V to two VMware ESXi 7.0.3 hosts, and one from Vmware Workstation 15.5.1 to the same hosts. As there is no longer any working tool from Vmware for a migration from Hyper-V to ESXi 7 I used StarWind V2V converter version to convert from Hyper-V to ESXi. But regardless of the settings in the conversion, the resultiing VM crashed with BSOD shortly after loading the VM OS. Next I uploaded a Win7 VM from Vmware Workstation via the tool integrated in VMware Workstation to the hosts. Initially the uploaded VM started and I could use and configure it. But after a certain time the VM stalled and Disk IO stopped completely without any error. Chkdsk reported no errors and Windows Repair from an installation DVD reported no errors, too. But now you could only start the VM and shortly after entering the logon credentials the VM stalled again. I did several uploads from Workstation to ESXi with similar results, I also exported the VM to OVF and deployed the OVF on the ESXi host with similar results and sometimes the VM BSODed with unaccessible boot device. I also installed a completely new Windows 7 32-bit VM from scratch. This VM worked initially well, but after installing SP1 and some other essential updates the VM stalled again with completely stopped Disk IO. Before the stalling I had copied a folder with some files, which suddenly stopped in the middle of the transfer, with the error, that the directory, to which copying occured, is write protected. And afterwards the machine stalled immediately after startup and entering the logon credentials. In the end I gave up on Windows 7 and have changed to WIndows 10 32-bit, which works quite well. To be sure, that the underlying hardware is not the culprit I tried to create the VM on SAN and on the local disks of two different servers all with the same result. My impression is, that the Windows 7 32-bit Disk drivers (I tried SCSi and IDE) or some Windows services interacting with the disk are unable to communicate correctly with the VMware Disk emulation running on the ESXI 7.0.3 host and at some point this crashes. Interestingly, if I attach the "corrupt" disks to other Windows VMs on the host (Windows 10 or Windows server 2019) I can read and write without any problem from and to the whole content of the disk. Has anybody seen similar behaviour?
0 Kudos
0 Replies