jimdavis77
Contributor
Contributor

Excel file refuses to load VBA in VM, still runs perfectly on metal

I cloned a Win 7 64 bit install I use daily using Vcenter Converter

Intel I-5

Windows 7 64

to run in a VM  running on a Ryzen3700x.

Everything seems to be working perfectly in limited testing except for 1 strange failure

I have an Excel 2007 workbook, that is perfectly happy on the original box.   I can  even open it  in Excel 2019 .   So the file itself is NOT corrupt .  Tested on multiple versions of the same workbook as well.

For some reason, this same file is refusing to load on the VM , throwing the "Excel has found unreadable content ....do you want to recover..."  error. 

It has a problem with the VBA code and wont load with it intact.    How is this possible ??  A clone is a clone, right ?

The only change I can possible see as affecting this , is the fact that the Office 2007 had to be re authorized, and it accessed the MSOcache install file on first boot .  Not sure why that would break it.

Also, I've tried other Excel files on this VM and they seem to run fine, VBA and all.   Just the one personal project that won't  load.

I tried deleting all EXD files (Excel ActiveX) , no luck .    Ran a repair on Office. No luck .   Haven't done a full reinstall of Office yet.

Does this sound like anything anyone has heard of before (lol, yeah I know)

0 Kudos
1 Reply
scott28tt
VMware Employee
VMware Employee

Moderator: Moved to Virtual Machine, Guest OS and VM Tools > Windows


-------------------------------------------------------------------------------------------------------------------------------------------------------------

Although I am a VMware employee I contribute to VMware Communities voluntarily (ie. not in any official capacity)
VMware Training & Certification blog
0 Kudos