TryllZ
Hot Shot
Hot Shot

DHCP Address From Host

Hi All,

I have a Windows Server 2012 R2, x64 and 3 clients set up in VMWare and this is in a local domain in the VMWare itself.

What happened was that the Windows Server was set up with a DHCP server to assign each of the clients IP when they join the domain. So the clients were joined to the domain [ipconfig /release, ipconfig /renew commands were run] but they never received the IP from the Windows Server, instead they received the address from the VMWare DHCP server. Then I found out that the first DHCP to receive the request issues the IP, so basically since the VMWare DHCP is the first one to receive the request on boot by the client, I disabled the VMWare DHCP from windows services.msc in host PC.

Now the issue is that when I check the Windows server there are 4 clients, 1 of which is the Host PC so basically after disabling the VMWare DHCP from services.msc even the host PC is fetching address from the Windows Server and NOT from the DHCP built into windows in services.msc.

Can any one explain me why this is happening.

The selected network for hosts and server n VMWare settings is Host-Only. When I change that to custom, I lose the internet on the Host PC itself because then there is no gateway when I checked it.

Host_PC.png

Host PC is added automatically and get its IP from from the Virtual Server

VMWare_DHCP.png

Windows_DHCP.png

0 Kudos
5 Replies
rcporto
Leadership
Leadership

First, instead of disable teh VMware DHCP Service, you can disable the DHCP for the VMware networks, just go to VMware Workstation, click on  Edit, click on Virtual Network Editor, select the Host Only network (usualy VMnet1) and uncheck the "Use local DHCP service to distribute IP address to VMs".

About the host getting IP from your virtual machine, go to your network adapters on host OS, look for VMware Network Adapter VMnet1, click properties and at TCP/IPv4 setting, assign an static IP address instead of use dynamic IP.

---

Richardson Porto
Senior Infrastructure Specialist
LinkedIn: http://linkedin.com/in/richardsonporto
0 Kudos
TryllZ
Hot Shot
Hot Shot

Hi Sir,

Thank you for the reply, yes indeed I ave turned off the DHCP assigning address to VMs from VMWare and the VMs now have the IP Windows Server still, yay!!..

But again for the Host PC receiving the IP from the VM, I disabled the whole VM network then all of my internet got disconnected and only got to find this out from the ipconfig command.

0 Kudos
TryllZ
Hot Shot
Hot Shot

What I meant was that the Host PC takes the Windows Server as the default gateway..

0 Kudos
rcporto
Leadership
Leadership

If you not configure the VMnet1 network adapter in your host to use static IP address, it will always get IP address from your Windows virtual machine that acts as DHCP server, see the image below:

VMnet1_settings.jpg

---

Richardson Porto
Senior Infrastructure Specialist
LinkedIn: http://linkedin.com/in/richardsonporto
TryllZ
Hot Shot
Hot Shot

Thank You Very Much Sir...

0 Kudos