VMware Cloud Community
gilad_benjamini
Contributor
Contributor

vmware-mount fails "The VMware fuse daemon failed to start"

I am trying to use vmware-mount to mount a virtual disk.

I am running the command on my linux machine, trying to access a virtual disk on an ESX4

My basic command (and outcome) looks like this

~$ sudo vmware-mount -h 1.2.3.4 -u root "\[Storage1\] my_vm/my_vm.vmdk" /home/user/mnt/my_vm

Failed to mount disk '\[Storage1\] my_vm/my_vm.vmdk': The VMware fuse daemon failed to start

Another variation

~$ sudo vmware-mount -h 1.2.3.4 -u root "\[Storage1\] my_vm/my_vm.vmdk" /home/user/mnt/my_vm

Failed to open disk: Unknown error (1)

Failed to mount disk '\[Storage1\] my_vm/my_vm.vmdk': The VMware fuse daemon failed to start

Further investigation shows that if I use 1.2.3.5, a non-existing IP address, the exact error messages appear.

I don't really who the 'VMware fuse daemon' is, and couldn't find anything of the sort.

Any ideas ?

Reply
0 Kudos
8 Replies
vm_arch
Enthusiast
Enthusiast

I seem to recall there was an error in the 1.0 RC of VMware Fuse that did exactly this.

Can you check the version of Fuse you are running

AFAIK the 2.0 RC fixed this.

Reply
0 Kudos
vm_arch
Enthusiast
Enthusiast

Found it:

http://communities.vmware.com/thread/161496

Could this be your prob?

Reply
0 Kudos
gilad_benjamini
Contributor
Contributor

When you say RC2.0, a version of what tool are you talking about ?

I got fuse for my Linux off the web.

I got vmware-mount as part of the latest VDDK, which I downloaded from VMware last week.

It all seems kind of recent.

Reply
0 Kudos
Tashi
Contributor
Contributor

Hi Benjamini,

I have the same issue as you. Have you solved it?

Mario

Reply
0 Kudos
giladb
Contributor
Contributor

I discovered, the hard way, that the link between vmware-mount error messages and the real problem is very vague.

"The VMware fuse daemon failed to start" in my case was resolved by adding the -F flag, pointing to a file with the password.

Reply
0 Kudos
Tashi
Contributor
Contributor

Thank you for reply.

Unfortunately the -F have not solved the problem.

Can you show me your "vmware-mount" command line?

Thanks

Mario

Reply
0 Kudos
giladb
Contributor
Contributor

sudo vmware-mount -h 10.10.21.127 -u root -F ~/pass_file "[NAS2] My_Mini_Linux_VI3/My_Mini_Linux_VI3.vmdk"

Reply
0 Kudos
Tashi
Contributor
Contributor

Thank you. Unfortunately it didn't work.

Reply
0 Kudos