VMware Cloud Community
evan_1
Contributor
Contributor
Jump to solution

vmkfstools - vmdk clone issues

Hello!

So I recently cloned two attached drives from two VMs in our PROD environment.

One of the VM was a Windows 2003 Guest (LSI LOGIC) and the other is a Windows

2000 (Buslogic) - adapters. Anyway, the clones completed successfully but now

when I want to attach the clone drives to another VM, the VM will end up

hanging at the Windows 2003 splash screen and never get to a point of login.

I've tried to just attach one at a time (i thought being one buslogic the other

lsilogic) was causing an issue but same outcome - Guest OS never loads hangs. I

looked at disk performance (real-time) to see if it was an I/O problem but

everything is normal.

Short Summary of environment- ESX 3.0.2, storage: SAN, network: gigabit, VC Centralized

Steps I took to clone:

vmkfstools -i /vmfs/volumes/<datastore1>/<VM folder>/EDrive.vmdk

/vmfs/volumes/<datastore2>/<VM Folder>/Copy-EDrive.vmdk (repeated

process for the other clone)

Thanks so much for help/input!

-Evan

Reply
0 Kudos
21 Replies
evan_1
Contributor
Contributor
Jump to solution

Problem Solved!

I removed the Extent, had our storage team present one 350GB LUN, rescanned

on all hosts, vmkfstools -i , attached – bingo boingGO

When I was prompted the question " Do you want VMware ESX Server to

change the adapter type for scsi0:3 disk?" which is the buslogic adapter I

attached I said ‘Yes’.

All is well. Thanks for both your guys help.

Reply
0 Kudos
kjb007
Immortal
Immortal
Jump to solution

No problem. Glad all is well.

-KjB

vExpert/VCP/VCAP vmwise.com / @vmwise -KjB
Reply
0 Kudos