VMware Cloud Community
evan_1
Contributor
Contributor
Jump to solution

vmkfstools - vmdk clone issues

Hello!

So I recently cloned two attached drives from two VMs in our PROD environment.

One of the VM was a Windows 2003 Guest (LSI LOGIC) and the other is a Windows

2000 (Buslogic) - adapters. Anyway, the clones completed successfully but now

when I want to attach the clone drives to another VM, the VM will end up

hanging at the Windows 2003 splash screen and never get to a point of login.

I've tried to just attach one at a time (i thought being one buslogic the other

lsilogic) was causing an issue but same outcome - Guest OS never loads hangs. I

looked at disk performance (real-time) to see if it was an I/O problem but

everything is normal.

Short Summary of environment- ESX 3.0.2, storage: SAN, network: gigabit, VC Centralized

Steps I took to clone:

vmkfstools -i /vmfs/volumes/<datastore1>/<VM folder>/EDrive.vmdk

/vmfs/volumes/<datastore2>/<VM Folder>/Copy-EDrive.vmdk (repeated

process for the other clone)

Thanks so much for help/input!

-Evan

Reply
0 Kudos
1 Solution

Accepted Solutions
kjb007
Immortal
Immortal
Jump to solution

Looks like there is a problem with the cloned copy you made. Is the INFRA-Copy2-flag.vmdk the disk you are trying to add?

Apr 24 10:00:13.751: vmx| DISKLIB-VMFS : "/vmfs/volumes/47f27140-d7c38969-1b62-00151723e500/INFRA-Copy2-flat.vmdk" : closed.

Apr 24 10:00:15.035: vmx| vmdbPipe_Streams Couldn't read: OVL_STATUS_EOF

Try the clone again.

vExpert/VCP/VCAP vmwise.com / @vmwise -KjB

View solution in original post

Reply
0 Kudos
21 Replies
kjb007
Immortal
Immortal
Jump to solution

Since it is a disk, you can add the disk while the vm is up. Not sure if you tried to add the disk while the vm was up. Once added, the disk will need to have its signature updated, so you should be able to go into disk management after adding, and you should be prompted to initialize the disk.

vExpert/VCP/VCAP vmwise.com / @vmwise -KjB
mike_laspina
Champion
Champion
Jump to solution

Hi,

Could you please clairify that these are secondary drives that you are trying to add to a VM or are they boot drive for a new VM definition?

Were they Dynamic or Basic volumes on the source VM?

What is the target VM's OS?

http://blog.laspina.ca/ vExpert 2009
evan_1
Contributor
Contributor
Jump to solution

These are secondary drives - just data on them, not boot drives and both are Basic drives on source VMs.

The target VM's OS that i am trying to attaching is Windows Server 2003

One thing i should mention, i had to add an extent to the LUN that was presented before i did these clones (our storage team didn't present enough the first time) - could having done this messed up anything? i wonder if i missed a step?

kjb007 - i tried to attach the drives while the VM is powered on but when i do a rescan in disk management everything freezes and i end up killing it.

Thanks very much for the help!

-Evan

Reply
0 Kudos
mike_laspina
Champion
Champion
Jump to solution

The extent is very likely were things went wrong. Was the expanded logical drive created from space on a single LUN which got partitioned or two separate vmdk disks in a span.

If it is vmdk based then you will need the other vmdk for that logical volume.

If the systems have network connectivity you do have the option to just create new and copy the data over with xcopy, but I suspect thats not the case.

http://blog.laspina.ca/ vExpert 2009
Reply
0 Kudos
evan_1
Contributor
Contributor
Jump to solution

I will have to ask how the extra space was presented - but i believe it was presented from another hard disk partition although i only see one active path which is the same as the original 299.99GB is on (i attached a screenshot of the LUN volume properties, if it helps).

Once i added the extent i made sure the total capacity was new and followed up by doing a rescan on all volumes/hosts.

esxcfg-vmhbadevs -m: This is the active LUN - vmhba0:6:0:1 /dev/sdk1 47f27140-d7c38969-1b62-00151723e500

Not sure what else to do besides removing the cloned vmdks and starting over?

Thanks!

Reply
0 Kudos
mike_laspina
Champion
Champion
Jump to solution

Oh!

I'm sorry, I thought you were refering to the VM logical drive as extended not the vmfs store. There is no issue with an extent on the vmfs store. This will not cause what you are dealing with now.

http://blog.laspina.ca/ vExpert 2009
Reply
0 Kudos
evan_1
Contributor
Contributor
Jump to solution

whew!

Reply
0 Kudos
kjb007
Immortal
Immortal
Jump to solution

Did you try adding the drives one at a time, or both at the same time. Try adding the LSI Logic drive first, and then rescan, while the vm is up. After you add, and after you click rescan, can you post that vmware.log?

-KjB

vExpert/VCP/VCAP vmwise.com / @vmwise -KjB
Reply
0 Kudos
evan_1
Contributor
Contributor
Jump to solution

Yeah, ive tried just adding the LSI Logic drive first.

Here is the vmware.log file from when i did a Hot add of the lsilogic drive, rescan in windows, lock up. Smiley Sad

I had to poweroff the VM to get the log file. Thanks much!

Reply
0 Kudos
kjb007
Immortal
Immortal
Jump to solution

Looks like there is a problem with the cloned copy you made. Is the INFRA-Copy2-flag.vmdk the disk you are trying to add?

Apr 24 10:00:13.751: vmx| DISKLIB-VMFS : "/vmfs/volumes/47f27140-d7c38969-1b62-00151723e500/INFRA-Copy2-flat.vmdk" : closed.

Apr 24 10:00:15.035: vmx| vmdbPipe_Streams Couldn't read: OVL_STATUS_EOF

Try the clone again.

vExpert/VCP/VCAP vmwise.com / @vmwise -KjB
Reply
0 Kudos
evan_1
Contributor
Contributor
Jump to solution

The "INFRA-Copy-flat.vmdk" is not the disk im trying to add - that is Hard Disk 1 w/ OS installed on it.

Apr 24 10:00:13.656: vmx| DISKLIB-VMFS : "/vmfs/volumes/47f27140-d7c38969-1b62-00151723e500/TAC-APP044-Clone/APP044_Copy-flat.vmdk" : closed.

This is the drive I'm trying to attach^

Hmmmm...

Reply
0 Kudos
kjb007
Immortal
Immortal
Jump to solution

I was just able to replicate what happened to you and then was able to add the disk. After you did the clone, did you move both of the vmdk files into the vm's folder that you are trying to add to?

When I made the copy, I left the disk where the original disk was, and I got the hung situation you received. I killed my vm, and removed the disk mapping. Then I moved both of the vmdk files (the flat and descriptor vmdk files) to the vm where I wanted to add. Then booted the vm back up, and logged in. Then adding the disk using the vi client, and rescanning for the disk in disk management was successful.

Not sure about the EOF file error though, but that could be the hang issue.

-KjB

vExpert/VCP/VCAP vmwise.com / @vmwise -KjB
Reply
0 Kudos
evan_1
Contributor
Contributor
Jump to solution

Dang! i tried copying over the vmdk files into the target VMs folder but still have an end result of locking up Smiley Sad

I attached the vmdk header and the .vmx file of the test VM im using - anything interesting?

I may end up having to clone these drives again. ...

Thanks for the input. Smiley Happy

Reply
0 Kudos
tlaurent
Contributor
Contributor
Jump to solution

This is just an observation - may not be relevant - but I noticed something that struck me odd in the log file posted. Shouldn't the number after /volumes/ be the same for all the entries?

Apr 24 09:52:19.750: vmx| changing directory to /vmfs/volumes/46239384-96d676c0-0618-00151719a9fa/TAC-AP171TST/.

Apr 24 09:52:47.861: vcpu-0| HBACommon: First write on scsi0:1.fileName/vmfs/volumes/47f27140-d7c38969-1b62-00151723e500/TAC-APP044-Clone/APP044_Copy.vmdk

Apr 24 09:52:47.880: vcpu-0| DISKLIB-CHAIN : UpdateContentID: old = 0xd92a56d9, new = 0xabff6f19

Apr 24 10:00:13.559: vmx| Stopping VCPU threads...

Apr 24 10:00:13.559: vcpu-0| VMMon_WaitForExit: vcpu-0: worldID=1365

Apr 24 10:00:13.577: mks| Async MKS thread is exiting

Apr 24 10:00:13.655: vmx| scsi0:1: numIOs = 0 numMergedIOs = 0 numSplitIOs = 0 ( 0.0%)

Apr 24 10:00:13.656: vmx| DISKLIB-VMFS : "/vmfs/volumes/47f27140-d7c38969-1b62-00151723e500/TAC-APP044-Clone/APP044_Copy-flat.vmdk" : closed.

Apr 24 10:00:13.656: vmx| DnD rpc already set to 0

Apr 24 10:00:13.656: vmx| TOOLS received request in VMX to set option 'enableDnD' -> '0'

Apr 24 10:00:13.657: vmx| SOCKET 2 close VNC socket on VNCBackendDestroy

Apr 24 10:00:13.660: vmx| MKS local poweroff

Apr 24 10:00:13.749: vmx| Lock before MKS lock created. Early poweroff?

Apr 24 10:00:13.749: vmx| Unlock before MKS lock created. Early poweroff?

Apr 24 10:00:13.750: vmx| scsi0:0: numIOs = 0 numMergedIOs = 0 numSplitIOs = 0 ( 0.0%)

Apr 24 10:00:13.751: vmx| DISKLIB-VMFS : "/vmfs/volumes/47f27140-d7c38969-1b62-00151723e500/INFRA-Copy2-flat.vmdk" : closed.

Reply
0 Kudos
kjb007
Immortal
Immortal
Jump to solution

hmmm. The vmx file does not look correct. It looks as though the description of disk 0 disappeared from the vm config file, and the only disk I see is the one you are trying to add. After you moved the disk, you did add update disk 2 with the new file location, and remove the old one? Just wanted to double-check.

-KjB

vExpert/VCP/VCAP vmwise.com / @vmwise -KjB
Reply
0 Kudos
evan_1
Contributor
Contributor
Jump to solution

Hello!

Sorry for the delayed response, been crazy busy!

Anyway, this weekend i will be cloning the drives again. For the Windows 2000 server I'm going to try and 'copy' the VM using Platespin(V2V). Because... Platespin has the ability to convert a Buslogic adapter to LsiLogic - I'd rather have both drives attached to the VM be LsiLogic rather than attaching a new SCSI BusLogic Controller.

I'll let you know how this goes. Thanks again for the help on this kjb and tlaurnet!

Reply
0 Kudos
tlaurent
Contributor
Contributor
Jump to solution

No problem! And congrats on passing the VCP!!!

Reply
0 Kudos
evan_1
Contributor
Contributor
Jump to solution

Hey, thanks!

I've been drooling over a free VM Workstation License!

:smileygrin:

Reply
0 Kudos
kjb007
Immortal
Immortal
Jump to solution

No problem! Let us know how it goes.

-KjB

vExpert/VCP/VCAP vmwise.com / @vmwise -KjB
Reply
0 Kudos