dingding
Enthusiast
Enthusiast

network device numbering in RH linux

i have a fedora VM, when i copy it to a new ESX. the network does not working. i log into fedora, and run /usr/sbin/system-config-network-gui. in devices tab, i can see device name is eth0 and is not active. in hardware tab, the actual adapter is eth2.

in CLI, when i run "ifconfig -a", i can only see eth2.

i can config eth2 and make it work. but how to make the adapter name from eth2 to eth0? maybe there are hidden adapters, and how to remove them?

---- Idleness is not doing nothing. Idleness is being free to do anything.
0 Kudos
4 Replies
TobiasKracht
Expert
Expert

Where it was created? What virtual hardware? did you re-installed VMTools?

StarWind Software R&D

StarWind Software R&D http://www.starwindsoftware.com
0 Kudos
dingding
Enthusiast
Enthusiast

the VM is fedora 11. vmware-tools is installed and virtual hardware version is 7.

---- Idleness is not doing nothing. Idleness is being free to do anything.
0 Kudos
kcollo
Contributor
Contributor

Could be your virtual switch setup on the ESX host. We have a lot of RedHat and CentOS based VMs that have had no issues. Unless you call setting the Ethernet card on the wrong vswitch. Physical to virtual conversion has worked great on all of our hosts as well.

--

Kevin Goodman

Linux / SAN / Virtualization

kevin@colovirt.com

http://blog.colovirt.com

0 Kudos
dingding
Enthusiast
Enthusiast

after install vmware-tools, modify file /lib/udev/rules.d/70-persistent-net.rules, and it's ok

---- Idleness is not doing nothing. Idleness is being free to do anything.
0 Kudos