Targray
Contributor
Contributor

VCB question

Just wondering if i'm totally screwed or if there's something I can do here... I'm running Exchange 2003 in a VM - the system (C) drive is a vmdk in my VMFS datastore - the database and logs are on their own seperate LUN.

My backend storage is a Dell Equallogic PS6000E. Originally I had the VM configured to map the data LUN as an RDM - but now I want to leverage off the Auto-Snapshot tools in the Dell Host Integration toolkit (this allows me to take application consistent snapshots of the data LUN for backup/dr purposes) so, I had to change from an RDM to mapping the LUN using the ms iscsi initiator within the VM. This works fine and I can create the LUN snapshots without a problem... but now I can't seem to use VCB to create a snapshot of the system drive for backup, I get the error:

Snapshot creation failed: Could not quiesce file system.

I came across the KB article http://kb.vmware.com/selfservice/microsites/search.do?cmd=displayKC&externalId=1009073

that states "If you are using Microsoft's iSCSI initiator within the virtual machine, you cannot perform snapshot operations on the virtual machine because it is not supported"

So does that mean i'm out of luck? It's hard to believe that I can't even create snapshots of the C drive (I don't care about backing up the exchange data with vcb)

Any help is much appreciated...

0 Kudos
2 Replies
NTurnbull
Expert
Expert

Hi, I haven't used the Dell Equallogic stuff before but how did you originally have your disks configured? System disk as .vmdk and your data disks as RDM's? If so, what RDM type were you using - virtual or physical?

I know that when using RDM's with the NetApp snap-manager for Exchange you've got to have the RDM's as physical mode so the snaps work. This would get around your limitation of using the ms iSCSI initiator. Maybe the same configuration is supported with your Dell Equallogics?



Thanks,

Neil

Thanks, Neil
Targray
Contributor
Contributor

Thanks for the response - in the end I was able to resolve it by configuring the Dell tools to perform CHAP authentication with the SAN (when VCB attempted to create the snapshot of the C drive it was also attempting to create a snapshot of the E drive on the SAN, but would fail because of CHAP authentication)

It now works perfectly!

0 Kudos