VMware Cloud Community
daspazz
Contributor
Contributor
Jump to solution

Question about controlling power up/down of Guest OS from Host OS

Hey all, a total VMWare noobie here. ?:|

I am running power testing (UPS power up/down) and need to know how to get the guest OS to do orderly shutdowns when using UPS control software to shutdown startup the host system. I have VMWare 3.01 installed and I also install VMwaretools on the guest OS (Windows 2003 RS SP2). When I initiate a shutdown from the UPS the host OS shuts down, but the guest OS acts as if it lost power. Also when I restart the system. The guest OS does not restart automatically as I expected it too.

Any ideas on what to check?

Thanks in Advance for any support you can offer.

0 Kudos
1 Solution

Accepted Solutions
virtualdud3
Expert
Expert
Jump to solution

Glad I could help.

Please post back if it works (if it doesn't, we'll make sure it does!!!)

############### Under no circumstances are you to award me any points. Thanks!!!

View solution in original post

0 Kudos
10 Replies
virtualdud3
Expert
Expert
Jump to solution

When configuring the Startup order, did you move the VMs up to the "Automatic Startup"? If the VM is still "under" the "Any Order", it won't startup automatically.

Regarding the Shutdown, make sure that "Guest Shutdown" is selected for "Shutdown Action".

(The above steps refer to connecting via the VI client-> Configuration tab -> Virtual Machine Startup/Shutdown)

############### Under no circumstances are you to award me any points. Thanks!!!
daspazz
Contributor
Contributor
Jump to solution

Wow, I am such a noobie!!! :_|

I forgot about the hierarchical "tree" in the VI interface. I was wondering were the "other" configuration information was!

Once I clicked on and hi-lighted the VMware (host) in the left window I could then see all the high level configuration and information tabs!! :smileyblush:

Now I can "See" the tab for the HOST configuration and you are correct, I can also find "Virtual Machine Startup/Shutdown setting under software.

I now have it configured to stuartup and shutdown based on the host OS!!

Thanks for your help!!

0 Kudos
virtualdud3
Expert
Expert
Jump to solution

Glad I could help.

Please post back if it works (if it doesn't, we'll make sure it does!!!)

############### Under no circumstances are you to award me any points. Thanks!!!
0 Kudos
daspazz
Contributor
Contributor
Jump to solution

The above fixed my main issue. But revealed a sub issue.

When power agents initiate a shutdown i get the following error.

"vmkmod_load panic : resource busy or not responding"

When I restart the guest server starts ok and if I check eventvwr I get the following error;

"The previous system shutdown at 1:14:50 PM on 10/23/2007 was unexpected."

0 Kudos
virtualdud3
Expert
Expert
Jump to solution

Hmmm...

Did you change the "Shutdown Action" from the default of "Power off" to "Guest Shutdown"?

(VI Client->ESX Host->Configuration->Virtual Machine Startup/Shutdown then click "Properties")

You can set the Shutdown Action either at the "Default" level or per each virtual machine.

If you confirm that the Shutdown Action is set to "Guest Shutdown", try to shutdown the VM via the service console:

#vmware-cmd /vmfs/volumes/datastore/VM/VM.vmx stop trysoft

############### Under no circumstances are you to award me any points. Thanks!!!
0 Kudos
Nautilus
Enthusiast
Enthusiast
Jump to solution

Butttttt Smiley Happy

its not possible to configure the shutdown order. I Think this option will be very helpfull. Because i want to shutdown first the application Server in a definied order and in the lest step the DCs.

Maybe in Version 5.9 of VMWare Smiley Happy

Have a nice day

Kind regards Nautilus ________________________________________________________________________________________________________________________________________________ If you found this or any other post helpful please consider the use of the Helpfull/Correct buttons to award points
0 Kudos
daspazz
Contributor
Contributor
Jump to solution

Your command worked once I found my vmx file. I got a responce of

stop(trysoft) = 1

And start trysoft restarted the guest OS.

So what might I try checking now.

0 Kudos
virtualdud3
Expert
Expert
Jump to solution

Well, you can specify the appropriate "Shutdown Delay" to have the VMs shutdown in the desired order.

############### Under no circumstances are you to award me any points. Thanks!!!
0 Kudos
virtualdud3
Expert
Expert
Jump to solution

Have you made sure to specify the Shutdown Action as "Shutdown guest virtual machine" as opposed to "Power off"?

############### Under no circumstances are you to award me any points. Thanks!!!
0 Kudos
daspazz
Contributor
Contributor
Jump to solution

Yes I did and yes it is set as you specified.

I will try a shutdown today and see what happens.

Opps, now I see I missed something in the error before.

It actually looks like this;

"vmkmod_load panic : vmfs3 : resource busy or not responding"

0 Kudos