ajbrehm
Enthusiast
Enthusiast

Installing VMware Tools without WoW64

Jump to solution

I noticed that I cannot upgrade VMware Tools from 6.0 and 6.5 to 6.7 on Windows Server 2016 VMs that do not have WOW64-SUPPORT installed.

The Tools installer says it cannot access the Windows installer service.

When I add WoW64 to the VM's OS the installer works.

I couldn't find any KBs about that (although about the error message). Any ideas? This is on vSphere 6.7.

0 Kudos
1 Solution

Accepted Solutions
sybi
Contributor
Contributor

Yes, setup64

The thing is even with the newest vmware tools 10.3.10 x64, this happens!

There is another problem, vmware is using since 10.3.5, c++ redistributables 2017

-> c++ redistributables 2017 is not installable without WOW64-Support...

+ vmware-tools 10.3.10 is not installable without WOW64-Support...

At the end, we cannot use vmware-tools without WOW64.

For me this is a blame, because, we are using "Windows Server 2019 Core"

Server 2019 Core is supported since vmware-tools 10.3.5...

And there is not a single Application, we use that requires WOW64-Support...

except of vmware-tools and vcredist 2017, because vcredist is needed for vmware-tools....

--------------

There is a workaround i found out, but it will (maybe break vmware-tools)

After you installed vmware-tools, you can remove WOW64-Support again...

(But there will be maybe some snapshot errors because vmware-tools quiesce scripts will (maybe) fail)

+ you need to install and remove WOW64-Support for evey vmware-tools update...

View solution in original post

0 Kudos
2 Replies
bluefirestorm
Virtuoso
Virtuoso

There is a setup.exe and setup64.exe in the Windows VMware Tools. Does the error also occur when setup64.exe is invoked instead of the usual setup.exe?

0 Kudos
sybi
Contributor
Contributor

Yes, setup64

The thing is even with the newest vmware tools 10.3.10 x64, this happens!

There is another problem, vmware is using since 10.3.5, c++ redistributables 2017

-> c++ redistributables 2017 is not installable without WOW64-Support...

+ vmware-tools 10.3.10 is not installable without WOW64-Support...

At the end, we cannot use vmware-tools without WOW64.

For me this is a blame, because, we are using "Windows Server 2019 Core"

Server 2019 Core is supported since vmware-tools 10.3.5...

And there is not a single Application, we use that requires WOW64-Support...

except of vmware-tools and vcredist 2017, because vcredist is needed for vmware-tools....

--------------

There is a workaround i found out, but it will (maybe break vmware-tools)

After you installed vmware-tools, you can remove WOW64-Support again...

(But there will be maybe some snapshot errors because vmware-tools quiesce scripts will (maybe) fail)

+ you need to install and remove WOW64-Support for evey vmware-tools update...

View solution in original post

0 Kudos