VMware Cloud Community
manicmog
Contributor
Contributor

HP RDP - WinPE boot issue's

Hi

I have a test VM with Win2k3 Enterprise and HP RDP (altiris) 3.5 for test.

I also have a another VM that can PXE boot to the RDP server OK. However if the server uses WinPE to boot it freezes (it pulls down the WinPE image then says please wait). If it uses DOS to boot is works OK.

Has any one experianced similar issues ?

Thanks

Reply
0 Kudos
11 Replies
VirtualKenneth
Virtuoso
Virtuoso

Let me try that this afternoon, I've got the same testing environment over here.

Reply
0 Kudos
J-D
Enthusiast
Enthusiast

Hi,

installing RDP 3.5 as we speak. I'll try it out later on.

In the mean time: are you sure your RDP 3.5 is okay? We had the experience where an ISO file was badly extracted and some files in a deep path were truncated. This resultated in weird phenomenons...

Will keep you informed.

J.

Reply
0 Kudos
sc_2111
Enthusiast
Enthusiast

did you change the Vmware VM BIOS Settings ?

Reply
0 Kudos
sc_2111
Enthusiast
Enthusiast

sorry , misundersttod the problem.

When it freeze what can you see on the screen ? is it trying to detect the hardware ?

Reply
0 Kudos
dickiesmart
Contributor
Contributor

I have just experienced the same issue having built a new v3.5 RDP server. We used to deploy servers with the v2.2 RDP and there were no issues deploying to a VMWare virtual machine.

I suspect that it relates to the supplied WinPE image not supporting the hardware that is emulated by the VMWare server although there are no error messages to suggest where the problem lies.

I know that the WinPE boot methodology was added to provide x64 deployment support but in most other areas it appears to be a step backwards :o(

Not sure what the best way forward here is given that there is no failure information provided. The previous posting referred to the BIOS settings of the Virtual Machine, I have looked at these and don't see anything obvious that might cause the issue. The server PXE boots and downloads the WinPE image but then just displays the "Please Wait" message.

Any other ideas from the floor?

Reply
0 Kudos
Cary_MdDonald
Contributor
Contributor

I am having the same issue. I changed the SCSI controler to the BusLogix controler and it went past the hanging. Not sure if it will fail further into the install, but we will see.

Cary

Reply
0 Kudos
dickiesmart
Contributor
Contributor

Did it work for you?

I tried editing the .vmx configuration file to use the buslogic controller but the boot sequence fails at exactly the same point. There is also warning message that the BusLogic controller is not supported natively in W2K3 when you create a new VM so this doesn't look like a suitable solution.

I suspect the default WinPE image needs some additional drivers added but this is a complication i would rather avoid.

Dickie

Reply
0 Kudos
dickiesmart
Contributor
Contributor

I have just found the answer elsewhere, you need to increase the memory size of the virtual machine to at least 300MB for the deployment phase. You can lower it back once the build has completed.

http://altirisbe.blogspot.com/2007/02/ram-size-needed-to-run-winpe-through.html

I have just tried it successfully, still using the default LSI SCSI controller 🐵

Reply
0 Kudos
big_vern
Enthusiast
Enthusiast

altering RAM didn't solve for us, we had to go into rdp console and remove the tick for "x64" in tools - pxe configuration. then worked a treat.

Intrestingly we had no problem in deploying to physical boxes with RDP, just the virtuals (on esx 3.0.1)

Reply
0 Kudos
ggrayson
Contributor
Contributor

x64 WinPE is definitely the issue here....

Here's a link to HP's knowledgebase (http://h18013.www1.hp.com/products/servers/management/rdp/knowledgebase/00000180.html ) - not extremely informative, but it does acknowledge the issue being there after RDP version 3.1.

I went in to the PXE manager and in the DS tab hard coded the initial deploy option to WinPE x86 (default is WinPE auto-select). This took care of the issue for me.

Reply
0 Kudos
icampbell79
Contributor
Contributor

I'm running RDP 3.1 and it was the memory issue in my case. Once I increased it over 300MB it booted fine. Thanks Dickiesmart.

Reply
0 Kudos