Enthusiast
Enthusiast

HGFS Service fails to start

I've seen a few posts on this but no real solutions. I upgraded VM tools on a WIndows Server 2003 VM running on ESX 3.5 U3 today. After the upgrade of tools I am now getting an extremely long boot up time for the VM and an error in the system log that the "HGFS service failed to start due to: system cannot find the specified file"

Has anyone seen this or resolved it?

Jeff

0 Kudos
8 Replies
Expert
Expert

You dont need HGFS driver in ESX VMs. edit your /etc/fstab file and comment the last 3 lines, 2 of them should be already commented saying that " dont modify some thing like that"

You should be fine after that.

Let me know if you need more help.

-Surya

0 Kudos
Enthusiast
Enthusiast

for modifying the fstab are you referring to the ESX host? If you are referring to the VM, I am not dealing with an LX VM but a WIndows VM

Jeff

0 Kudos
Expert
Expert

I should have asked you what Guest OS, My mistake. You can start the tools installation again and select "Modify" choose custome installation and ensure HGFS drive is not installed.

You should be fine after that.

-Surya

0 Kudos
Enthusiast
Enthusiast

When I modify the Vmware tools isntall, I do not see any reference to hgfs. . .the "Shared folders" option (which I think is related) shows as NOT installed already.

The error I am seeing is basically a "file not found" error. So, shared folders is NOT installed, the system thinks it is and is looking for a file. . .is that plausible?

This really seems like a bug in the tools install process.

Thanks for the insight so far. . .

Jeff

0 Kudos
Expert
Expert

You are correct HGFS == Shared Folder option. Looks like VMware tools server is trying to start and reporting file not found error. If this happened the first time after the tools installation i guess it is ok.

When you open the tools from the system tray you should see the shared folder disabled. If you see the error msg everytime you re-boot the VM then this could be a bug.

-Surya

Enthusiast
Enthusiast

It happens after every reboot of the VM. I opened an SR with support. . . I will post relevant findings once I work with support

Thanks,

Jeff

0 Kudos
Leadership
Leadership

once again the HGFS feature has caused problems for users,

why don't VMware just change the default for silent install of VMtools for Guests running under ESX.!http://planetvm.net/blog/wp-includes/js/tinymce/plugins/wordpress/img/trans.gif!

however the crux of the matter is do not install Vmware tools with

the complete option on ESX guests. This installs the shared folders

feature which is not available on ESX. This causes the VMware tools to

keep a file (hgfs.dat) open and can cause errors when logging off a

guest. To disable the shared folders feature, remove hgfs from the

registry key ProviderOrder under

KEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\NetworkProvider\Order\.

See for more information.

If you found this or any other answer useful please consider the use of the Helpful or correct buttons to award points

Tom Howarth

VMware Communities User Moderator

Blog: www.planetvm.net

Tom Howarth VCP / VCAP / vExpert
VMware Communities User Moderator
Blog: http://www.planetvm.net
Contributing author on VMware vSphere and Virtual Infrastructure Security: Securing ESX and the Virtual Environment
Contributing author on VCP VMware Certified Professional on VSphere 4 Study Guide: Exam VCP-410
Enthusiast
Enthusiast

I worked with VMware support. For reference, here are the steps they gave me. Working through the registry modification on the VM corrected the issue. Standard warnings apply: You are modifying the registry, so make sure you backup the hive you are working in and ensure you have a good backup of the VM.

Also, VMware made the following statement about why hgfs is provided in ESX VMs:

"The module is included in vmware-tools for ESX to allow VMs to be migrated more easily to hosted products like Workstation."

Here are the steps for disabling the hgfs module:

Disable the hgfs.sys service from running at boot time inside of the virtual machines by following these steps.

Caution: This procedure involves modifying the registry. Incorrect changes to the registry can leave your system unstable or unable to run. Always back up the registry before editing it, and exercise caution in making changes to the registry. VMware takes no responsibility for problems that might arise.

1. Choose Start | Run

2. Type: Regedit

3. Click OK.

4. Navigate to the key:

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\hgfs

5. Right-click the key and choose Export.

6. Export the key to a location on your hard drive.

7. Change the Start value of the key to 4.

8. Import the changed value by using one of the following methods.

Method 1:

Browse to the file using Windows Explorer and double-click the file.

Method 2: At the command prompt, type:

regedit /i /s c:\<location of exported file>hgfs.reg

9. Reboot the guest operating system.

0 Kudos