VMware Cloud Community
bludden
Contributor
Contributor

Explorer.exe and idle CPU usage higher in VMs

Hi all,

I have been going crazy trying to figure out this problem that is affecting the performance of my VMs.

When I first deploy a VM from template and create a new 2CPU VM, everything works great. After a while (a couple of days?), however, the CPU usage at idle goes from about 2-4 percent to 8-12 percent, and when I open something like "My Computer", the CPU temporarily spikes to 50 percent or higher. On my (dual core dual proc) physical machines this is never a problem, and all are patched identically. I have put off post VM creation patches and AV install on a test system, but it has not helped. If I log in as the local admin so I do not have any network drives to map, the performance is the same.

Memory usage seems OK, I run 16 bit color 1024x768 in the console, no CDs attached, running Server 2003 with LSI logic on the latest VMWare Tools. Page file usage is quite low and set to system managed. This has happened on servers running IIS as well as Citrix - the Citrix performance, even for the few users that use the VM servers, is unacceptable, and below my experiences with Citrix VMs in the past.

Has anyone seen this type of behavior?






Brian

Brian
Reply
0 Kudos
11 Replies
eagleh
Enthusiast
Enthusiast

i had some similar problems in the past. you didn't say any information on your virtual environment though.

If you found this information useful, please kindly consider awarding points for "Correct" or "Helpful". Thanks!
Reply
0 Kudos
bludden
Contributor
Contributor

Actually I did a lot of testing today and might have found the solution. The VMs that are giving my grief are primarily 2 CPU VMs (ESX 3.5). I shut a couple of them down and changed them to run on one CPU. Restarted....and CPU use was back to 2-4% at idle, with explorer.exe taking much less resources.

Shut down the VM, added the 2nd CPU....and it still worked correctly!

I really have no idea why this is the case. The Template VM was built from the get go with VCPUS, and when they first come up all seems fine.

Maybe you can try this and see if you have any luck!

Brian

Brian
Reply
0 Kudos
kjb007
Immortal
Immortal

One other thing to try that I've seen on the boards is to add Workload = "Terminal Services" in your vmx file for Citrix and/or RDP servers. This should help with performance as well.

I've found that using 1 vCPU vm's works better for most applications, but in some scenarios the vSMP does help, but more often that not, 1 vCPU will give you very good if not better performance than the vSMP.

-KjB

vExpert/VCP/VCAP vmwise.com / @vmwise -KjB
Reply
0 Kudos
williambishop
Expert
Expert

I know you figured it out on your own, and others have also said it, but especially on desktops, it rarely makes sense to use more than one vcpu. You will also get a lot less density on your hosts going this way.

--"Non Temetis Messor."
Reply
0 Kudos
eagleh
Enthusiast
Enthusiast

This was my fix. under ESX host configuration, Advanced settings, Mem, Mem.VMOverheadGrowthLimit, change the default 0 to 5

It is said the ESX3.5 Update 1 has included this fix.

If you found this information useful, please kindly consider awarding points for "Correct" or "Helpful". Thanks!
Reply
0 Kudos
williambishop
Expert
Expert

What is this repairing?

--"Non Temetis Messor."
Reply
0 Kudos
eagleh
Enthusiast
Enthusiast

FYI.

If you found this information useful, please kindly consider awarding points for "Correct" or "Helpful". Thanks!
Speedbmp
Enthusiast
Enthusiast

Also check this post out

http://communities.vmware.com/thread/144173

Stephen

Reply
0 Kudos
bludden
Contributor
Contributor

This is some great information - I've followed the testing procedure listed in the first link and that did not seem to be my problem, but it seems to me that an issue like this would give me the wierd things I've been seeing. I will continue to let everyone know how its going on my end - so far I've gotten the expected performance out of about 5 of my VMs by changing the CPU to 1 (in some cases, then change back to 2) and also there were a couple of VMs that had custom page file settings that i set to system managed.




Brian

Brian
Reply
0 Kudos
bludden
Contributor
Contributor

Just as an update...

This issue is still a problem here - after a few days of operation, some VMs creep back up to the high idle and the way high explorer.exe usage - rebooting the server does not help; however a shutdown and restart does. This would indicate to me an issue with the way that the virtual CPU is interacting via the ESX system to the physical layer. On one of my farms, I implemented the memory setting change as described above - it's only been a few days but it looks like machines that have been shut down and restarted are working ok so far, there are a couple of machines that have not been shut down that are exhibiting the symptoms.

I am using HP BL460c G1 blades, dual core dual proc @2.666GHz with 20GB RAM each, connected to an HP SAN via fiber channel.

I am going to open a call with HP VMWare support and let you all know if I get anywhere...






Brian

Brian
Reply
0 Kudos
bludden
Contributor
Contributor

As another update -

I saw this same problem happen today on a one CPU machine. I am going to try to open a case with VMWare and get some more info...


Brian

Brian
Reply
0 Kudos