nehaban
Contributor
Contributor

Exchange VM getting hung after backup

Jump to solution

Hi,

I have strange issue where after backup my VM gets into hung state and i had to reset it to bring back up.

Did anyone face the same issue?

1 Solution

Accepted Solutions
bansne
Enthusiast
Enthusiast

This could possibly due to quiesce option enabled. or , To avoid this issue, disable the SYNC driver or stop the service generating heavy I/O before taking a snapshot.

Under heavy loads, the delay in I/O can become too long, which affects many time-sensitive applications, including the services which generate the heavy I/O (such as an Exchange Server). If writes issued by these services get delayed for too long, the service may stop and issues error messages.



View solution in original post

3 Replies
bansne
Enthusiast
Enthusiast

what is the level of backup configured is it image level or data disk ?

nehaban
Contributor
Contributor

Its full VM backup configured to take snaphshot .

Backup triggers the quiescing of the VM and flushes the disk contents out of the file system cache.

0 Kudos
bansne
Enthusiast
Enthusiast

This could possibly due to quiesce option enabled. or , To avoid this issue, disable the SYNC driver or stop the service generating heavy I/O before taking a snapshot.

Under heavy loads, the delay in I/O can become too long, which affects many time-sensitive applications, including the services which generate the heavy I/O (such as an Exchange Server). If writes issued by these services get delayed for too long, the service may stop and issues error messages.



View solution in original post