knatesan
Contributor
Contributor

Does CPU hotplug supported in Linux64 bit VM

Jump to solution

hi,

I have ESX4.0 setup.

Can i add the vCPU in online to the linux64bit VM. (without reboot)?

Will it Linux64 bit supports?

Appreciate any kind of clue!

Thanks,

kamal.

0 Kudos
1 Solution

Accepted Solutions
AndreTheGiant
Immortal
Immortal

I haven't try yet...

But see this document:

Andre

Andre | http://about.me/amauro | http://vinfrastructure.it/ | @Andrea_Mauro

View solution in original post

0 Kudos
8 Replies
AndreTheGiant
Immortal
Immortal

I haven't try yet...

But see this document:

Andre

Andre | http://about.me/amauro | http://vinfrastructure.it/ | @Andrea_Mauro
0 Kudos
knatesan
Contributor
Contributor

Any Windows Based OS(64bit) will support this CPU hot plug ?

Appreciate your help!

0 Kudos
AndreTheGiant
Immortal
Immortal

As I know only with Windows 2008 (x64 or x86).

With 2003 (enterprise or datacenter) only the memory hotadd.

See also:

http://vmlover.blogspot.com/2009/05/hot-add-cpu-vsphere.html

Andre

Andre | http://about.me/amauro | http://vinfrastructure.it/ | @Andrea_Mauro
0 Kudos
knatesan
Contributor
Contributor

andre, Highly appreciate your response.

BTW,i have tried with win2k8 DC edition 64 bit . its not working.. I am not able to see the option to change the vCPU online.

Does it require any script to do ( windows environment)?

0 Kudos
AndreTheGiant
Immortal
Immortal

I've only tested memory hot-add on Windows.

But must work also CPU hot-add on Windows 2008 Datacenter (without scripts):

http://www.rtfm-ed.co.uk/?p=1367

Andre

Andre | http://about.me/amauro | http://vinfrastructure.it/ | @Andrea_Mauro
knatesan
Contributor
Contributor

Andre,

In my win2k8 DC 64 bit VM , i see hot cpu/memory add is in disabled state.

2k8VM-> edit setting->options-> Memory/CPUhot plug is in Disabled state.

How do i make this enable? i guess because of this, VC is also not showing me the option to add the hot CPU.

0 Kudos
AndreTheGiant
Immortal
Immortal

You can change the options only for a powered off VM.

And be sure that the VM has the right OS specified in the properties.

Andre

Andre | http://about.me/amauro | http://vinfrastructure.it/ | @Andrea_Mauro
0 Kudos