VMware Cloud Community
kostic
Contributor
Contributor

Cloning time on ESX 3.0

Hi,

Just got our new ESX servers and started to play with it. To create clone of Windows 2003 Server with 40G HDD it takes almost 3 hours. Is it good or not?

For me it looks quite slow as 20G VM machine was cloned within 20-30 minutes on our another server running free VMware Server on the top of Win 2003.

If the 3 hours cloning time is not about to be right, could you advice where the problem could be ( we use DELL 2950 server and DELL AX1500i storage) ?

Thanks in advance, Kostic

Reply
0 Kudos
4 Replies
virtualdud3
Expert
Expert

3 hours to clone a 40GB hard disk (well, .vmdk) is unusually long.

In my experience, when clones take a long time to complete the problem is the SAN. Do the ESX servers have any local storage disk available to them? You could try creating/cloning say a 10GB VM on the local storage the repeat with the VM on the SAN and compare the times. This will at least help narrow-down whether or not the bottleneck is with the SAN.

You also may want to re-think having a 40GB VM as a "base image". It might make more sense to break-up your VMs to use one .vmdk for the OS and use, say, a 10GB VM as a "base image", and clone this 10GB VM as necessary. For the clone VMs, you can then add a second 30GB or 40GB or whatever size .vmdk to store data, etc.

###############

If you found this information useful, please consider awarding points for "Correct" or "Helpful". Thanks!!!

############### Under no circumstances are you to award me any points. Thanks!!!
formulator
Enthusiast
Enthusiast

I assume you mean AX150i. Have you logged into the AX150 to see if something is wrong? I know it's common for the cache controller to be disabled on the AX100 boxes when there is or was a problem with the device, wouldn't be surprised if this is the case with the AX150 also. Are you connecting via iSCSI?

Reply
0 Kudos
kostic
Contributor
Contributor

Thanks for your reply!

Yep, It's AX150i , sorry for my mistake.

It is connected via vlan and it's on iscsi. Cisco switch shows about 30mbit traffic per second on the 1Gbit vlan.

AX150i does not show any problems. I have no idea where cache controller can be enabled, but I'll find out and check it.

Thanks for your help!

Reply
0 Kudos
kostic
Contributor
Contributor

Thanks for your comments and suggestion. I'll try to create and clone PC on local storages, as we have two dell servers working in esx cluster.

Each server still have 60Gb availble to play with.

What would be avarage speed for cloning VMs?

Something about 1G per minute as I got on Vmware Server?

We have HW servers with 72Gb HDD on each, so for VMs we decided to go down to 40 Gb.

Thanks a lot !

Reply
0 Kudos