vohra
Contributor
Contributor

Why libexpat is not bundled with the VDDK?

The advanced accelerated transport modes plugin needs libexpat library version 1.95.7. But I am not sure why this

is not bundled with the VDDK distribution. We are VMware Tech Alliance partner and are bundling VDDK

along our application; but our deployment is facing this problem. Any ideas will be appreciated.

Since if we have to build libexpat from source we are not sure which build options to use or not to use.

Thanks.

0 Kudos
8 Replies
hubs
Contributor
Contributor

Same question...

vohra, where did you see the required version was 1.95.7 ?

0 Kudos
vohra
Contributor
Contributor

This information can be found in the open source license text file bundled as part of the

installation.

0 Kudos
admin
Immortal
Immortal

I am not quite sure if that is correct - let me verify and respond.

Thanks

Sudarsan

0 Kudos
tos2k
Expert
Expert

Sudarsan, please post a guide on how to install libexpat for VDDK.

Tos2k

ps: Please answer questions VMware.

0 Kudos
admin
Immortal
Immortal

Sorry, I missed this totally, I will check and update.

Thanks

Sudarsan

0 Kudos
admin
Immortal
Immortal

For 1.1 :

For Windows 32 bit versions 1.95.7 is used.

For Windows 64 bit and Linux 1.95.8 is used.

1.2 uses 1.95.8 for all platforms.

Thanks,

Sudarsan

0 Kudos
tos2k
Expert
Expert

I have libexpat installed on my server, and reinstalled vddk 1.2

Still no hotadd comes up under supported transport modes...

Why? What can I do?

How can I verify that "everything" is properly installed/configured?

Tos2k

0 Kudos
tos2k
Expert
Expert

Hi!

Cant you please post som info on how to get advanced transport modes up and running?

Tried Debian and Ubuntu, installed libexpat, vddk 1.2.1, but advanced transport modes are never listed...

Default modes work as expected.

Any help appreciated!!

Tos2k

0 Kudos