BaluT21
Contributor
Contributor

VDDK 7.0 - Cannot get compatible version for vim

When using the VDDK7.0.2, i am getting the below error. Can someone guide us:

The VM has virtual hardware version 14. Not able to figure out the issue in regards to compatible version. We use an older connectSpec

=========

[110] [VddkUtil::diskLibLog] VixDiskLib: VixDiskLibConnectInt: Failed to start session. Cannot get compatible version for vim at 5720.

[110] [VddkUtil::diskLibLog] VixDiskLib: VixDiskLib_ConnectEx: Advanced transport modes not available for opening moref=vm-17604. (Cannot use advanced transport modes for 10.10.01.01/moref=vm-17604/snapshot-17607: Cannot get compatible version for vim.)

[110] [VddkUtil::diskLibLog] VixDiskLib: VixDiskLib_OpenEx: Open a disk.

[110] [VddkUtil::diskLibLog] VixDiskLib: VixDiskLib_OpenEx: Failed to start session. Cannot get compatible version for vim at 7149.

[110] [VddkUtil::diskLibLog] VixDiskLib: VixDiskLib_Open: Cannot open disk [DS] New Virtual Machine/New Virtual Machine.vmdk. Error 1 (Unknown error) at 7250.

========

 

0 Kudos
6 Replies
BaluT21
Contributor
Contributor

Even tried with VMs from VMFS 5 and VMFS 6, but still the connect fails with 

=======

[110] [VddkUtil::diskLibLog] VixDiskLib: VixDiskLibConnectInt: Failed to start session. Cannot get compatible version for vim at 5720.

[110] [VddkUtil::diskLibLog] VixDiskLib: VixDiskLib_ConnectEx: Advanced transport modes not available for opening moref=vm-17604. (Cannot use advanced transport modes for 10.10.0.1/moref=vm-17604/snapshot-17625: Cannot get compatible version for vim.)

=======

Any help would be appreciated.

0 Kudos
panmankan
Contributor
Contributor

Hi,

 

Were you able to find any solution for this problem, please post in case you fixed the problem.

Thanks.

0 Kudos
BaluT21
Contributor
Contributor

No. we are still figuring out 😞

0 Kudos
panmankan
Contributor
Contributor

Thanks BaluT21. I tried few things but no luck yet. We were using vimservice.dll from older VI SDK, upgraded that to use 7.0.2 VI SDK but still the issue persists. From VMWare side it would be really helpful if they can provide more information on what exactly is not compatible instead of just throwing error saying that vim version is not compatible. Also, it may even be a bug from their side, what do you think ??

0 Kudos
BaluT21
Contributor
Contributor

By calling VixDiskLib_InitEx() in designated thread, the issue seems to be resolved now.

0 Kudos
BaluT21
Contributor
Contributor

 

the below suggestion from VDDK 70 release notes helped us:

New: On Windows, backup applications should call VixDiskLib_InitEx at the very beginning of the program. Some thread local storage was introduced in VDDK 7.0, so now all threads that call VixDiskLib functions must be created and initialized after calling VixDiskLib_InitEx. This is advised but not required for Linux.

0 Kudos