VMTN_Admin
Contributor
Contributor

Ultimate Deployment Appliance

http://www.vmware.com/vmtn/appliances/directory/232

Deploy your favorite OS by pressing F12, bring your own ISO's, we'll do the rest

0 Kudos
672 Replies
echrist1
Contributor
Contributor

I was able to download the UDA via bittorrent after the site repair this weekend, so I think that problem may be resolved. But of course there are others...

I'm not able to access the web interface, as I'm not sure what I'm supposed to do. At this point I have one physical machine, completely disconnected from any networks, running the UDA. The UDA starts, and I see it is running dhcpd, but it doesn't assign IP addresses to any of my host machine's ethernet adapters. Should it assign an IP address to one of the adapters, and if so, which one? I've tried setting static IP addresses for each of the three adapters (physical, VMnet1, VMnet8), but I've been unable to connect to 10.0.0.104. How is this supposed to work?

Dude, have you thought of starting a howto wiki? It could allow users to post tips on overcoming obstacles that you might find trivial and not bother to explain.

Message was edited by:

echrist1, to reflect correct IP address

0 Kudos
_the_dude_
Enthusiast
Enthusiast

echrist1, make sure your host machine has a static adress (e.g. something like 10.0.0.50). The DHCP service is only for the machines in the network that will be deployed. Leave the VMNet1 and 8 alone (i'm not sure what the default settings are, either reset them to the way you found them or reinstall the VMWare software)

When you have booted the UDA you now have 4 adapters:

The physical machine: static 10.0.0.50

VMNet1: default

VMNet8: default

The UDA: static 10.0.0.104

By the way in your post you mention 10.0.0.4 whereas the default UDA adress is 10.0.0.104

Type in your internet browser (on you windows host platform) http://10.0.0.104 and you should see the webinterface...

The WIKI is a good idea, i'll have to look into that.

0 Kudos
echrist1
Contributor
Contributor

Thank you for your help. I am now able to access the web interface. It didn't work when my physical server was completely disconnected, but when I hooked up the physical server to another powered computer using an ethernet cord, I was able to access 10.0.0.104. Somehow it seemed having a "live connection", even though the connection didn't lead anywhere in particular, was the missing ingredient.

So now I have another question. In the walkthrough on the web interface, you say "Make sure you do not use easy sharing, since we need a real username and a real (non-empty) password later on," when describing how to set up the shared folder. What is "easy sharing", and how do you get windows to prompt for a username and password for shared folders?

BTW, the UDA doesn't appear as an adapter on the physical server, where I attain the list of adapters through Control Panel -> Network Connections.

0 Kudos
echrist1
Contributor
Contributor

My friend helped me to figure out how to require a username and password for shared folders. You need to go to Control Panel -> Administrative Tools -> Local Security Policy -> Local Policies -> Security Options -> "Network access: Sharing and security model for local accounts" and change it to "classic". This will enable many more options than were previously available in the "Properties" meta-data of the folder you want to share.

So I have another problem. I'm able to properly mount the folder, as it is accessible on the UDA at /var/public/smbmount/, but when I try to import the OS from the ISO (step 5), the iso that I want to use doesn't appear in the drop-down list. Any ideas?

0 Kudos
_the_dude_
Enthusiast
Enthusiast

Try to view the source of the web-page (in internet explorer do View->Source) where you would expect the iso file to show up. It should look something like this if you have 2 isofiles in the shared directory:

classarray[0]='winxp;winxp.iso'

classarray[1]='winxp;xp.iso'

If the iso file is mentioned then you probably do not have javascript enabled. It seems that Pulse had trouble using firefox with default settings, but Internet Explorer seems to work with default settings.

Check out this page on how to check/enable/disable javascript in your favorite browser.

http://www.mistered.us/tips/javascript/browsers.shtml

0 Kudos
echrist1
Contributor
Contributor

So I had enabled javascript in Firefox, but it must not have been completely enabled, because it worked in IE.

The next problem is that the web interface returns an error when it tries to "Create STARTROM". Do you know how to fix this?

0 Kudos
_the_dude_
Enthusiast
Enthusiast

echrist1,

Some hints:

1. Please try creating a template that does not have the name WINXP, winxp, WI2KS, wi2ks, WI2K3 or wi2k3 this will mess things up... try something like 12345 for example. dont use slashes, backslashes e.g. Also before using configure OS delete all templates with these names...

2. I could generate the error when trying to create a template while the OS was not configured yet. So please make sure that you went through the 'configure' step for the OS you're trying to deploy and that there were no error messages when the configure was run.

3. The create startrom procedure does 2 things:

First it copies the file

/var/public/tftproot/WINXP_EXTRA/STARTROM.N12

to

/var/public/tftproot/.0

using a sed command.

For both steps there should be an OK on the output web page. If there is only an error you're sure that the first step has failed. If there is an OK first and then an error you know that the second step has failed...

4. please check the logfile of the web-server:

/var/log/httpd/error_log

there should be an error message in there.

5. Make sure the OS mount is working properly. Unmount the OS image and mount the OS image again.

By the way the wiki is a good idea, as you may have noticed the project is not very stable yet...

0 Kudos
echrist1
Contributor
Contributor

Dude,

Thank you for you detailed post. But as it turned out, it was a permission problem - it seems like read access to the iso is insufficient, and you must enable "full permissions".

The next problem I faced was getting a network driver to the target computer, but I was able to solve that using the excellent advice you gave to Pulse. I also have an intel card, so it might make sense to include the intel driver in the default driver repository in the next version of the UDA.

So this is hopefully my last problem. I get the blue screen, it starts to load components, and then it says something like "hidusb.sys is corrupt". Is that file supplied by the UDA, or is it supposed to retrieve that from my mounted iso? BTW, that file doesn't seem to be in the iso, though it does have a file called "HIDUSB.SY_". Also, I know the iso is not corrupt.

Do you have any ideas?

0 Kudos
_the_dude_
Enthusiast
Enthusiast

echrist1,

You're right, good thing you found that out. I remember struggling with trying "Read Only" instead of "Full Access" indeed months ago, but i did not remember why. Now I remember Smiley Happy The walktrough also mentions it but I'll make the words "Full Access" bold in the next version of the UDA and add some more explanation about it...

Now for yout hidusb.sys problem.

You are probably using a keyboard or a mouse connected with USB. If you can try using a ps/2 mouse and keyboard do that before reading further. That might do the trick.

The problem is a little bug from microsoft. The new client tries to get a file that's not there. The client tries to retrieve a file that has a lowercase filename while the actual file on the CD is in uppercase (or the otherway around).

I'm assuming you use Windows XP here. To fool the UDA into serving the right file after all do the following:

1. Extract the file hidusb.sy_ to the directory containing more of these problems to a filename with all capitals

cabextract -p /var/public/tftproot/WINXP/i386/hidusb.sy_ > /var/public/tftproot/WINXP_EXTRA/HIDUSB.SYS

2. Go to the tftp config in the web interface and add the following under the windows XP section:

rgi /WINXP/i386/HIDUSB.SY_ /WINXP_EXTRA/NONEXISTENT

rgi /WINXP/i386/HIDUSB.SYS /WINXP_EXTRA/HIDUSB.SYS

Press 'Apply' and try again.

0 Kudos
echrist1
Contributor
Contributor

Dude,

I've done what you suggested, and I still get the error, "The file hidusb.sys is corrupted." I've verified that the cabextract created a file in WINXP_EXTRA called HIDUSB.SYS, and I added the two lines to the tftpconfig.

Do you have any more ideas?

The computer is a Portege M200, and I'm trying to install a volumized (corporate license, from my school) version of WinXP.

0 Kudos
echrist1
Contributor
Contributor

School starts for me on Monday, and I need a computer, so I installed WinXP with the following technique:

1) take the HD out and put it in a computer with a cdrom drive

2) install DOS on the HD using cdrom (can't use WinXP)

3) copy XP install cdrom directory into a directory that DOS can see, optionally copy SMARTDRV.EXE to root of DOS FS (to speed up WinXP install).

4) put the HD back into the target machine

5) if you had used WinXP here, you wouldn't be able to boot, but DOS is sufficiently hardware agnostic that you can get a command line

6) optionally run SMARTDRV.EXE, and then run WINNT.EXE, which is located in the I386 subdirectory of the install CD folder.

7) end with XP on a FAT parition; optionally use partition magic or like program to change partition to NTFS

I recommend that if anyone wants to try this, they buy a $10 IDE to USB adapter to greatly simplify things. Also, the paritioning scheme for the target HD should have a 5+ GB FAT partition as the first partition; this is where you'll install DOS.

The UDA represents a significantly quicker and more robust solution to diskless installs, so if you have time, I'd still like to get it working.

0 Kudos
stavener
Contributor
Contributor

hi, ive got it all setup to deploy fc5 from a DVD iso image, but im getting `bad http response` when the client is starting the fedora setup. its asking for IP & HTTP url details, which ive got configured as..

IP=192.168.0.100 (ip of my uda server)

url=http://192.168.0.100/fedora/fc5/Fedora

which looks to be the correct path... but its complaining that it cannot find this. ive checked the path on the server (/var/public/www/fedora/fc5/Fedora) and it all look ok, i can see the files on the mounted iso.

one thing, on the setup screens, it shows http://192.168.0.100//fedora/fc5/Fedora - with double quotes in the middle but ive tried all variations on the http config line but no success.. any help please ?

0 Kudos
_the_dude_
Enthusiast
Enthusiast

echrist1, if/when you try again, please check out the /var/log/messages files. It should mention what files are being requested for download over tftp. The tftp configuration is generally a set of rewriting rules. The /var/log/messages also mentions what the rewriting rules do and which file (if any) is being returned to the Portege. I think that there's some kind of problem with the uppercase/lowercase filenames that are either requested or returned. Use the log!

0 Kudos
_the_dude_
Enthusiast
Enthusiast

Stavener,

Please do some checks:

\* If you're using a virtual machine to deploy, check the Vitrual machine network card settings Check that the network card of the system to deploy is configured as 'Bridged'

\* Edit the configuration file and try removing the last 'Fedora'

the line in the kickstart file should say something like this for you:

url --url=http://192.168.0.100/fedora/fc5/

\* During the fedora install press ALT-F3 and/or ALT-F4 for debugging info of the anaconda installer.

\* See if you can download the configuration/kickstart file manually:

browse to http://192.168.0.100/kickstart/12345.cfg

(replace 12345 with the name of your template (case sensitive))

\* See if you can download one of the installation files manually. Browse to

http://192.168.0.100/fedora/fc5/Fedora/TRANS.TBL

\* During installation (or when the installer asks for IP and http location) press ALT-F2 and in the shell try to:

ping 192.168.0.100

if you get a ping reply you know that the network connection is working. Now try to download a file throug http from the shell as well:

wget http://192.168.0.100/fedora/fc5/Fedora/TRANS.TBL

Let me know what happened...

0 Kudos
stavener
Contributor
Contributor

Hi, thanks for the quick reply... in answer to the checks...

im building a laptop.

kickstart file is exactly as you have quoted.

debug info on Alt-F3 shows an error...

URL_STAGE_MAIN - url is `INFO : http://192.168.0.102//fedora/fc5//Fedora/base/updates.img to a fd`

`ERROR : got to setupCdrom without a CD device`

i can download the kickstart files ok.

I cannot download files from the fedora folder. i copied the index.html file to the fedora folder and tried to download, i get `500 : internal server error`

im only a novice linux user so im getting stuck here.

0 Kudos
_the_dude_
Enthusiast
Enthusiast

Stavener,

\* It might be Something wrong with the ISO file. Please check the MD5 sum of the DVD iso file you have downloaded. Here's a windows tool for that:

http://www.pc-tools.net/win32/md5sums/

\* Please check the logfile of the webserver (/var/log/httpd/error_log) you manual download (that resulted in internal server error) should have left an error in there. Please post the error message(s)

\* Did you try the wget command as suggested from the ALT-F2 shell on the laptop? Is that the command that resulted in an internal server error?

\* It might also be an unsupported other device (some weird SCSI cdrom e.g.). Did you try googling for your laptop hardware type and fedora core 5?

0 Kudos
stavener
Contributor
Contributor

Hi, i tried it on a VM and got the same error, so i gave up and downloaded your smaller 1.2 image, started again and its working now... same DVD iso.

thnks.

0 Kudos
_the_dude_
Enthusiast
Enthusiast

Stavener, the 1.2 image is based on Fedora Core 5. I've found that FC5 works better when mounting an iso file on a mounted windows share. I Can't think of another explanation.

But anyway, good to hear that it worked and thanks for your feedback!

0 Kudos
pulse
Contributor
Contributor

Hi,

When I was having trouble installing WinXP on my laptop, and I installed Fedora as a temporary OS until I could get it running, I had the same 'bad http response' errors.

I checked through the apache config and everything else, and it actually turned out to be that the http server with the Fedora files on it was busy. I hacked it to use a local mirror (my ISPs) instead of the default and it worked instantly.

I'd say it's probably not to do with downloading the smaller UDA, rather the time you tried again later the server wasn't so busy Smiley Happy

0 Kudos
_the_dude_
Enthusiast
Enthusiast

Pulse,

thanks for the tip! i'll do some intensive testing with Fedora deployment. I still suspect the mounting process though. The iso image is mounted on a directory that is served by the webserver. The iso image itself is found on a windows share that is mounted as well. In a way the files are served over 2 mounts. It sounds like the webserver has trouble doing this, but as said, i'll be testing that.

The newer, FC5 based UDA seems to be better at mounting (mounting windows shares is considerably faster an more stable now...). Your workaround is also a good idea. Maybe it's a good idea to add an option to the UDA to use an external fedora tree.

0 Kudos