Highlighted
Contributor
Contributor

NSX Manager Won't Automatically Configure Itself When Deployed Using the OVFTool

Jump to solution

Hi!

This puzzles me..

I have previously been able to deploy my NSX Manager Appliance without any problems..

The command below successfully deploys the NSX Manager appliance. However, the appliance is not able to set the passwords and IP.

When the appliance boots for the first time I have to log in with the default username and password.

Next, I have to run the "setup" command to set the IP address.

What could be wrong? Is there something missing in the deployment command?

I can successfully resolve the hostname of the appliance from the ESXi hosts, PSC and VCS. I am also able to ping between all of them.

The exception is the NSX appliance. I am only able to get a successful ping reply after I run the setup command, and reboot the appliance.

./tools/ovftool/ovftool --acceptAllEulas --allowExtraConfig --prop:vsm_cli_passwd_0=XxXXxxX!01 --prop:vsm_cli_en_passwd_0=XXXxxxXX!01 --prop:vsm_hostname=mgmt-nsxm.z01.virtlab.local --prop:vsm_ip_0=172.31.10.18 --prop:vsm_netmask_0=255.255.0.0 --prop:vsm_gateway_0=172.31.0.1 --prop:vsm_dns1_0=172.31.0.2 --prop:vsm_domain_0=z01.virtlab.local --prop:vsm_ntp_0=172.31.0.2 --prop:vsm_isSSHEnabled=False -ds=ds01-mgmt-c01h02 -n=vs_mgmt_nsxm --network=temp_NSX ../05_Repo/VMware-NSX-Manager-6.2.1-3300239.ova vi://172.31.10.10/mgmt-sddc/host/mgmt-c01/mgmt-c01h02.z01.virtlab.local/

Opening OVA source: ../05_Repo/VMware-NSX-Manager-6.2.1-3300239.ova

The manifest validates

Source is signed and the certificate validates

Enter login information for target vi://172.31.10.10/

Username: administrator@virtlab.local

Password: ***********

Opening VI target: vi://administrator%40virtlab.local@172.31.10.10:443/mgmt-sddc/host/mgmt-c01/mgmt-c01h02.z01.virtlab.local/

Deploying to VI: vi://administrator%40virtlab.local@172.31.10.10:443/mgmt-sddc/host/mgmt-c01/mgmt-c01h02.z01.virtlab.local/

Transfer Completed               

Warning:

- ExtraConfig option 'keyboard.typematicMinDelay' is not allowed, will skip it.

- ExtraConfig options exists in source.

Completed successfully

Best,

H

Message was edited by: Havard

0 Kudos
1 Solution

Accepted Solutions
Highlighted
Contributor
Contributor

The solution is to include the "--powerOn" switch in the command


In my lab I did not want the appliance to automatically boot, because I wanted to reduce the amount of RAM to 8GB before I powered it on.


The correct approach in a lab environment would be to let the appliance boot using the "--powerOn" switch in the command and then power it off once it has booted up for the first time.


Next, power the appliance off and reduce the amount of RAM, and then power it back on.

View solution in original post

0 Kudos
1 Reply
Highlighted
Contributor
Contributor

The solution is to include the "--powerOn" switch in the command


In my lab I did not want the appliance to automatically boot, because I wanted to reduce the amount of RAM to 8GB before I powered it on.


The correct approach in a lab environment would be to let the appliance boot using the "--powerOn" switch in the command and then power it off once it has booted up for the first time.


Next, power the appliance off and reduce the amount of RAM, and then power it back on.

View solution in original post

0 Kudos