brugh
Enthusiast
Enthusiast

ESX deployment appliance v1.05

Jump to solution

https://solutionexchange.vmware.com/store/products/esx-deployment-appliance-eda

ESX Deployment Appliance (EDA) is a small and easy to use appliance

that makes deploying ESX servers a breeze. It has a very intuitive

web-interface that can configure and deploy dozens of ESX servers in

minutes. It has a script-builder that will allow any admin to create

%post-scripts that will do most anything one needs to get the ESX hosts

up and running! Even if deploying with RDP/Altiris or the UDA, this

script-builder can help setting those up very quickly.

850 Replies
brugh
Enthusiast
Enthusiast

if you remove the NIC, you may also want to remove the persistent rules files. if you dont you'll end up with eth1, eth2 etc and all EDA scripts are built for eth0.

you can go either to alt-F2 and log in with root/root or go to the patch menu in eda and type 'rm /etc/udev/rules.d/*.rules' from the 'exec' box.

0 Kudos
HerwinGGZ
Contributor
Contributor

Hi Brugh,

Thank you for your answer, i could not find the key combo alt F2. your suggestion did the trick, remove network card, dit clear rules, and added network, rebooted. now the nic works en config is saved.

So my problem is solved!:smileyplus:

0 Kudos
esarakaitiscbts
Enthusiast
Enthusiast

I'm having a problem where the copy function is not working on the kickstart editor.

Apache is throwing a timeout on scr.php

Screen Shot 2013-07-11 at 9.31.05 AM.png

Any ideas?

0 Kudos
brugh
Enthusiast
Enthusiast

yeah *cough*, that bug's been in there for a while.

if you change line 31/32 in /var/www/eda/ajax.php from:

  •     $a1=current($this->ar);
  •     while (key($this->ar)!=$id) $a1=next($this->ar);

to

  •     while ( ($a1=next($this->ar)) && key($this->ar)!=$id ) { }

all should be well again.

0 Kudos
vkadiyala
Contributor
Contributor

burgh

do you know when 1.0.6 will be available for download.

0 Kudos
rock0n
VMware Employee
VMware Employee

Vielen Dank für Ihre E-Mail

Ich bin bis zum 2. August 2013 nicht im Hause.

Ihre E-Mails werden gelesen aber nicht weitergeleitet.

Bei dringenden Fragen wenden Sie sich bitte an:

mailto:training@techdata.de

Mit freundlichen Grüßen

Raiko Mesterheide

Thank you very much for your E-Mail.

I am not in the office and will return on 5th august 2012.

EMails will be read but won't be forwarded

For urgent issues please contact:

mailto:training@techdata.de

Best Regards

Raiko Mesterheide

Tech Data GmbH & Co. oHG, Sitz der Gesellschaft ist München, Amtsgericht München HRA 81177, WEEE-Reg.-Nr.: DE57403598; Gesellschafter: Sitz der Gesellschafter ist München; Tech Data Deutschland GmbH, Amtsgericht München HRB 81681, Geschäftsführer: Joachim Braune, Michael Dressen, Thomas Kasper, Raf Leenen, Marc Müller; Tech Data Midrange GmbH, Amtsgericht München HRB 90433, Geschäftsführer: Joachim Braune, Michael Dressen, Thomas Kasper, Raf Leenen, Marc Müller; Tech Data Information Technology GmbH, Amtsgericht München HRB 87050, Geschäftsführer: Samy Amsellem, Philippe Bosquier

0 Kudos
vkadiyala
Contributor
Contributor

burgh

I am trying to build ESXi 5.1 Update 1 with EDA Appliance 1.05. Everytime when it is trying caching the required files I get error message "Cannot open file [Errno 2] No such file or directory: '/tardisks/scsi_bnx.v01'

I am using a custom ESXi 5.1 Update 1 cd and it install fine when i try to install it from cd

eda error.jpg

0 Kudos
brugh
Enthusiast
Enthusiast

is that from a default VMware image or from a vendor's build (HP, Dell)?

what do you see when you go to the 'patch' menu and type 'ls /var/lib/tftpboot/cd/esx' in the 'exec' box?

does that file 'scsi_bnx.v01' exist there? or anything similar?

0 Kudos
wuytens20111014
Contributor
Contributor

Dear,

I am out the office today (Wednesday 07/08/2013). Your mail will be threated tommorow when i am back.

thx for your understanding.

PS.: I will be on holiday from 12-26 August

0 Kudos
brugh2
Contributor
Contributor

I have a preliminary 1.10 in my lab that I'm making ready for 5.5 deployments. should be available soon after VMware releases 5.5 officially

brugh2
Contributor
Contributor

that shouldn't happen.. are you sure you hit 'import PXE files' in the EDA?

can you post a (partial) screenshot of your eda where you type 'cat /var/lib/tftpboot/boot.cfg' in the 'exec' box from the 'patch' menu?

0 Kudos
roekoe
Contributor
Contributor

Hello,


Although the person who had the problem don't respond anymore i can confirm that a "Import PXE files" is the solution for the '/tardisks/scsi_bnx.v01' problem.

0 Kudos
brugh
Enthusiast
Enthusiast

thanks for that feedback. usually when people don't reply anymore it means that things are working again Smiley Wink

0 Kudos
Zsoldier
Expert
Expert

I love the appliance as is, use it all the time.  I have a thought.  Ever thought about adding a multi-script option?  This would make it easier to deploy several different hardware configs from one EDA appliance rather than deploy several EDA appliances for each spec.

Chris Nakagaki (中垣浩一)
Blog: https://tech.zsoldier.com
Twitter: @zsoldier
0 Kudos
brugh
Enthusiast
Enthusiast

i've had that request a couple of times but because of the way i built it, that would require quite a large rewrite. i usually advice people to use the backup/restore function on the EDA to do basically the same thing with a couple of extra clicks. i could extend the backup/restore option so switching between configs would be a bit easier (=intuitive). would that help?

0 Kudos
Zsoldier
Expert
Expert

Hmm, that might.  I'm always up for 'easier'.  Thanks. Smiley Happy

Chris Nakagaki (中垣浩一)
Blog: https://tech.zsoldier.com
Twitter: @zsoldier
0 Kudos
tomtom1
Enthusiast
Enthusiast

Hi, can someone please tell me how can I use EDA to do SAN boot. Please explain with examples.

Thanks

Tom

0 Kudos
Zsoldier
Expert
Expert

So, unfortunately it's not always a straight forward answer.  I only demonstrate for UCS systems, but here is my best attempt from that perspective.

Assuming the following:

  • Fiber Channel SAN
  • ESXi 5.0

For EDA in the "installdisk" parameter: =fnic

EDAUCS.png

Standard 5.0 U2 or newer ISO will work.

Server Profile:

Boot Order, 1. LAN (So you can PXE boot), 2, SAN

You need to target your Directors/Storage Processors where the LUN will be delivered from.

LUN ID delivered should be standardized from your array.  Most often this should be LUN ID 0 or 1, but that is your preference.  I would just recommend you remember that 'preference'.

Chris Nakagaki (中垣浩一)
Blog: https://tech.zsoldier.com
Twitter: @zsoldier
0 Kudos
Zsoldier
Expert
Expert

Have you ever seen this error before?  /cd/esx/OpenMana.v00?

OpenMana.png

Chris Nakagaki (中垣浩一)
Blog: https://tech.zsoldier.com
Twitter: @zsoldier
0 Kudos
Zsoldier
Expert
Expert

Nevermind, I've just realized my incredibly dumb mistake.  I imported the OpenManage vib into my ESXi image and importing the PXE boot image using that causes the above error.  I made a new image w/o it and it worked just fine.  :smileycry:  The perils of shortcuts.

On the other hand, not sure why EDA has a problem w/ this particular vib since booting directly off the iso works just fine.:smileyconfused:

Chris Nakagaki (中垣浩一)
Blog: https://tech.zsoldier.com
Twitter: @zsoldier
0 Kudos