brugh
Enthusiast
Enthusiast

ESX deployment appliance v1.05

Jump to solution

https://solutionexchange.vmware.com/store/products/esx-deployment-appliance-eda

ESX Deployment Appliance (EDA) is a small and easy to use appliance

that makes deploying ESX servers a breeze. It has a very intuitive

web-interface that can configure and deploy dozens of ESX servers in

minutes. It has a script-builder that will allow any admin to create

%post-scripts that will do most anything one needs to get the ESX hosts

up and running! Even if deploying with RDP/Altiris or the UDA, this

script-builder can help setting those up very quickly.

850 Replies
bulletprooffool
Champion
Champion

Try removing the vNIC from your appliance and re-adding it.

Also, are you running this on workstation, or ESX(i) - either wya, make sure that you are using the correct networking type for the NIC to allow traffic flow

One day I will virtualise myself . . .

View solution in original post

0 Kudos
tsmit
Contributor
Contributor

This solution from Brugh works perfectly:

Importing the EDA into an  environment can cause it to redetect the network card. since a while,  linux tries to keep all network cards it ever knew to a their specific  ethX device. this works fine for physical environments but for virtual  appliances it disturbs flexibility.

luckily  there's an easy fix; just remove the files from /etc/udev/rules.d and  reboot. (in EDA go to the patch menu and type 'rm /etc/udev/rules.d/*'  in the exec box).

i think i'll put a quick fix in the next patch release. Smiley Wink

0 Kudos
tsmit
Contributor
Contributor

Hi Brugh,

This fix works. Even when executed by a non linux guy. Smiley Happy

Thanks.

Grt.

Tom

0 Kudos
Mozana
Contributor
Contributor

Please pardon my ignorance but Im having the issue with the network adapater not being recognized so I cant assign it an IP and access the gui.   Where and how do i edit the /etc/udev/rules.d directory?   I assume this directory is located on the EDA appliance but I cant seem to figure out how to get to the command prompt on the appliance to make these changes.

Any help is appreciated.

Thanks

0 Kudos
tsmit
Contributor
Contributor

Go to the screen of your appliance. Probably you will see the menu for configuration and shutdown/reboot etc.

Activate your window.

use ALT-F2 to go to the login in screen.

Login with username/password (defaults).

then type at the prompt cd /etc/udev/rules.d

then type rm *

then type reboot.

After this you should be able to modify your IP address etc. without losing it at a reboot.

Goor luck.

0 Kudos
Mozana
Contributor
Contributor

Perfect, its now working!!!

Thanks

0 Kudos
tsmit
Contributor
Contributor

Maybe I'm a little old-fashioned but I tried to make a backup of the configuration in EDA 0.95 but I do get an error ("Page not found")

I'm clicking the "backup/restore configuration" option and get the window for backup and restore. Choose backup and get that error.

When I do look at the definition of the backup "key" I do see "http://192.168.73.249/dl/eda-bkup-2011-03-24.tar.gz" where "192.168.73.249" is the IP address of the EDA server. What went wrong over here??

I do have two EDA servers, both having the same problem.

Anyone some solution for this, because I want to backup my configuration before changing it.

Thanks

Greetings from Holland

Tom

0 Kudos
brugh
Enthusiast
Enthusiast

seems it broke in my effort to make the appliance as clean as possible before packaging it up. the fix is easy though:

in the patch menu, type this in the execbox:

chown www-data /var/www/dl

and all's well again Smiley Wink

0 Kudos
tsmit
Contributor
Contributor

You're great, but I suppose you allready know. Smiley Happy

Thanks.

Grt.

Tom

0 Kudos
ChrisDearden
Expert
Expert

I've got my EDA up and running but suspect I'm going to hit a few problems.

Testing with a virtualised ESXi guest initially - all of the PXE stuff is running fine , but I get an error that its not finding either /dev/sda or /dev/cciss/c0d0  ( depending on which option I select )

However when I actually "go live" with it , I'm going to be booting UCS blades from a SAN. The blades only have a single 6GB LUN zoned into them ( everything else is on NFS ) - what will I need to do in order to enable the HBA drivers and modify the ks.cfg file to install to the first disk it can find ?

If this post has been useful , please consider awarding points. @chrisdearden http://jfvi.co.uk http://vsoup.net
0 Kudos
vkadiyala
Contributor
Contributor

Hi there

how do i change the defualt keyboard layout. It is currently set to UK.

0 Kudos
Arrow1
Enthusiast
Enthusiast

Thank you for contacting me. I am out the office with poor mail connectivity. I will handle your email as soon as I will be back (March 30).

This e-mail and any attached files are confidential, intended solely for the use of the addressee, and may be legally privileged. If you are not the intended addressee, you are hereby notified that any disclosure, reproduction, copying, distribution or other dissemination or use of this e-mail is strictly prohibited. If you have mistakenly received this e-mail, please notify us immediately and then delete this e-mail from your system. This e-mail sent to and from our company is professional in nature and may be monitored to ensure compliance with internal policies and to protect our business. This e-mail does not constitute a commitment by Altimate-Group, unless it contains an express statement to the contrary from an authorized representative. This e-mail and its transmission cannot be guaranteed to be secure or error free as they can be intercepted, corrupted, amended, lost or destroyed, arrive late, or contain viruses. Altimate-Group or its affiliated entities are in no way liable for any errors or omissions in the content of this e-mail. Thank you.

Regards Bernard
0 Kudos
heskez
Contributor
Contributor

I've got this wonderful toy finally operational!

The first problem I encountered was the failure to bring up eth0. This was quite fast resolved thanks to Brugh's advice to remove the content from /etc/udev/rules.d/

The second problem resided in our vlan configuration and according Brugh's remark "Use native untagged vlan" we were able to find a workable solution.

At the last stage we got an error message which told us the appliance couldn't find a suitable disk. That one was fixed due to Brugh, to change the line(s) in the ks script or at the /var/www/ks/ks4i.php file

clearpart --firstdisk=local --overwritevmfs

autopart --firstdisk=local --overwritevmfs

to:

clearpart --firstdisk --overwritevmfs

autopart --firstdisk --overwritevmfs

By removing "=local" the appliance is going to look for a disk itself, which in our case was our RAID controller.

You probably don't want to mess with these settings because when there are SAN LUNS present and seen by the system at first, the'll be overwritten.

Brugh, thank you very much for your advice in this matter!

0 Kudos
Mozana
Contributor
Contributor

Hello All......I am having trouble getting this appliance to work with in our tagged network environment.   We are currently using native VLANs and have the EDA appliance on the same VLAN and Subnet as the ESX hosts.  The initial pxe boot process works fine, it allows me to type in the name of the ESX host I am trying to build, but when the ESX Host attempts to read the installation file after the initial boot, it times out with the following error message:


Host Screenshot Error Log (Screenshot attached)

"Error (See Log for more info):
"Error connecting to the network"
"Did not get an IP Address fro DHCP server"

Here is a copy of the switchport config (I only have 1 nic connected to the ESX host for testing)

interface GigabitEthernet1/0/16
description VM23A
switchport access vlan 142
switchport trunk encapsulation dot1q
switchport trunk native vlan 142
switchport trunk allowed vlan 2-4094
switchport mode trunk
switchport voice vlan 501
srr-queue bandwidth share 10 10 60 20
srr-queue bandwidth shape  3  0  0  0
priority-queue out
spanning-tree portfast
service-policy input IPPHONE
end

My Appliance IP info

172.18.142.205

255.255.255.0

172.18.142.1


DHCP Config

# Sample configuration file for ISC dhcpd for Debian
#
# $Id: dhcpd.conf,v 1.4.2.2 2002/07/10 03:50:33 peloy Exp $
#

allow booting;
allow bootp;

# option definitions common to all supported networks...
option domain-name "XXXX.local";
option domain-name-servers 172.20.2.147;

option subnet-mask 255.255.255.0;
default-lease-time 600;
max-lease-time 7200;

subnet 172.18.142.0 netmask 255.255.255.0 {
  range 172.18.142.215 172.18.142.220;
  option broadcast-address 172.18.142.255;
  option routers 172.18.142.1;
  next-server 172.18.142.205;
  filename "pxelinux.0";
}

Any help is appreciated

Thanks

0 Kudos
heskez
Contributor
Contributor

Looks like you're having the same problem as we had. What we did is configure a different native untagged vlan on the switchport of the ESX host.  The same vlan number we used tagged for the deployment appliance.

0 Kudos
Zsoldier
Expert
Expert

Having problems w/ dhcp.  Service keeps failing to start and says check syslog for diagnostics.  I upgraded to 0.95 from 0.91.  The dhcp service stopped working after I applied my backup file from 0.91.  Any ideas?  Tried checking myself, but I can't seem to find the logs related to the dhcp service to troubleshoot what it's complaining about.

Chris Nakagaki (中垣浩一)
Blog: https://tech.zsoldier.com
Twitter: @zsoldier
0 Kudos
Paul1010
Contributor
Contributor

Hi

I am having some problems uploading the HP Management agents for deployment to my ESX servers. If I try and connect to \\<IP-Address>\dl$ using windows explorer I get a message saying "The network path was not found"  If I use a web browser I get a HTTP 404 error.  If I use a web browser and connect to \\<IP-Address>\dl I get a page displaying the index of /dl, but using windows explorere I get a message saying "The network path was not found".  Do I have to activate access to the upload area on the EDA?  If so how can I do this?

Regards

Paul

0 Kudos
aty
Enthusiast
Enthusiast

Hi all,

I'm trying to deploy esx 4.1U1 on some new hp dl460c G7 blades.

Since the regular vmware esx iso image doesn't contain the needed drivers for the nc 553i 10GE FlexFabric converged network adapter, I'm using the one from hp (http://h30507.www3.hp.com/t5/Eye-on-Blades-Blog-Trends-in/HP-images-of-ESX-and-ESXi-for-G7-server-bl...).

A manual installation with this iso is not a problem but using the eda I'm runnning into an error. After loading all the drivers ('driver loading complete') the following message apears:

installation aborted

This system does not have a network interface card that is plugged in, or all network interface cards are already claimed.  Installation cannot continue as requested
Press <return> to reboot...

I'm using the .95 version of eda

the ks file looks like this

vRanger_Inst_050.png

Does anyone have a clue what the problem might be?

0 Kudos
aty
Enthusiast
Enthusiast

Problem solved. I got it to work by changing the initrd.img.

0 Kudos
KyleWeir
Enthusiast
Enthusiast

Has anyone tried to use EDA with ESXi 5.0 ? I tried and ran into some issues.

Yes I know there's the Auto Deploy, etc... but thats only if you have enterprise plus, which is expensive.

Also with the esxi 5 will the post scripts work since it doen't have a console? Any help would be appreciated, I am running v0.95 so it's not that.

Kyle

0 Kudos