brugh
Enthusiast
Enthusiast

ESX deployment appliance v1.05

Jump to solution

https://solutionexchange.vmware.com/store/products/esx-deployment-appliance-eda

ESX Deployment Appliance (EDA) is a small and easy to use appliance

that makes deploying ESX servers a breeze. It has a very intuitive

web-interface that can configure and deploy dozens of ESX servers in

minutes. It has a script-builder that will allow any admin to create

%post-scripts that will do most anything one needs to get the ESX hosts

up and running! Even if deploying with RDP/Altiris or the UDA, this

script-builder can help setting those up very quickly.

850 Replies
davismisbehavis
Enthusiast
Enthusiast

Is this you trying to import the OVF template to vSphere 4 on the Blade. There is a known issue with the OVF template file, there is a thread further up about downloading an alternative one.

Or is the problem with you deploying the image to a Blade server?

0 Kudos
francescog
Contributor
Contributor

I'm trying to import the OVF template to vSphere 4 on the blade, and I got the error.

Would you kindly direct me to thread you mentioned?

Thank you very much!

Francesco

0 Kudos
davismisbehavis
Enthusiast
Enthusiast

Download the alternative OVF from the following location Unzip it to the folder that the rest of the virtual machine is in, i.e. replace the OVF file you have already with this one. Now try and import it and it should work fine.

It will show up as EDA 0.88 but it does work with vSphere, presume this is merely cosmetic as opposed to any loss of functionality

francescog
Contributor
Contributor

It works! Thank you very much!

Francesco

0 Kudos
brugh
Enthusiast
Enthusiast

Ok! back from vacation I'm happy to see people helping eachother!

I also wanted to mention that is no more. the colo wanted 6x more money so i quit. all downloads and papers are being moved to in the resource section. if you're missing anything, let me know!

0 Kudos
SSOVMWARE
Contributor
Contributor

tot maandag 21 september 2009 ben ik afwezig. Voor dringende zaken kunt u contact opnemen met onze Helpdesk 070-3511001

0 Kudos
jusrr
Contributor
Contributor

Hello,

I am attempting to use the EDA to deploy ESX 4.0 hosts. So far it seems to only create ks files in the ESX 3.x syntax. Is ther a way to create 4.0 script?

J

0 Kudos
77seb77
Contributor
Contributor

Je suis absent jusqu'au 22 Septembre 2009. Merci d'ecrire à

ServiceDesk-FR@eads.com.

I am out of the office until September, 22nd 2009. Please write to

ServiceDesk-FR@eads.com.

Cordialement, Best Regards,

Sébastien BRIAND

Operations / IMS22 / DataCenter

EADS Defence and Security

MetaPole

1 Boulevard Jean Moulin

CS 40001

78996 ELANCOURT CEDEX

Tel : +33 (0)1 61 38 70 34

Fax: +33 (0)1 61 38 57 16

Email: sebastien.briand@eads.com

0 Kudos
davismisbehavis
Enthusiast
Enthusiast

Having successfully used the EDA appliance to upgrade 6 hosts from 3.0.2 to 3.5 U4 I am now looking at our production ESX infrastructure.

We have Vmotion running in Production so this is an additional consideration and I am looking for some advice about the best way to configure vmotion from a script.

What is available in the script editor is shown below, can someone tell me what the part in bold is doing? Is this some sort of network connectivity check?

  1. Dont edit the next line! check ks link in table of ESX hosts for output

esxcfg-vmknic -a VMotion -i ###HOSTIP### -n 255.255.255.0

service mgmt-vmware restart

sleep 5

while [ \$(vimsh -n -e "hostsvc/net/vswitch_info ; do

+ sleep 5+

+ echo Waiting for hostd to accept connections..+

done

vimsh -n -e "hostsvc/vmotion/vnic_set vmk0"

I'd come up with the following myself based on the above and a few posts I found on the internet. We only have one VMKernel port per server so presuming the VIMSH command below is right, any comments on the rest of it. Will this work?

  1. Create VMotion vSwitch add NICS, configure and enable VMKernel Port

/usr/sbin/esxcfg-vswitch -a vSwitch5

/usr/sbin/esxcfg-vswitch -L vmnic9 vSwitch5

/usr/sbin/esxcfg-vswitch -L vmnic5 vSwitch5

/usr/sbin/esxcfg-vmknic -a -i 10.10.0.40 -n 255.0.0.0 VMOTION

/etc/init.d/mgmt-vmware restart

/usr/sbin/vimsh -n -e "/hostsvc/vmotion/vnic_set vmk0"

Thanks in advance

D.Misbehavis

0 Kudos
Zsoldier
Expert
Expert

Any idea as to when ESX 4 HBA drivers will be removed from the PXE build process? Or does anybody currently have a work around for this?

K. Chris Nakagaki (Zsoldier)

Chris Nakagaki (中垣浩一)
Blog: https://tech.zsoldier.com
Twitter: @zsoldier
0 Kudos
brugh
Enthusiast
Enthusiast

that bold part is a waiting loop. if you restart the management service it is doing some work in the background that makes it unavailable for some time. so it requests some information and as long as it returns an error, it loops. once the information is passed correctly, it continues the script. if you try to issue the next vimsh command without waiting for the database (hostd) to be up, it will fail and the script will not complete succesfully.

0 Kudos
brugh
Enthusiast
Enthusiast

well it's on my todo list. but it requires some restructuring of the eda because the 3.5 image was only 2.5MB and was easily changed. the 4.0 image is 100MB. it's a bit of a pain to strip HBA drivers from that so it'll take some time before that's done.

as a workaround, the savest way is to either disconnect the hosts adapters or unpresent all LUNs. both are cumbersome but it's the only way to be sure. one trick you could use is to present a small dummy lun to your ESX servers as LUN0 and make it readonly. if for some reason the installer tries to write to the SAN it will exit with an error and not destroy any VMFS luns.

on the other hand, all hardware i've seen so far uses /dev/sda as the local harddisk because the order of scsi drivers is good and also strange cciss devices are no longer needed. unless you dont have local storage and boot from san, the local disk in esx4 is always sda.

0 Kudos
rosspcs
Enthusiast
Enthusiast

Did you ever get an answer to this ?

0 Kudos
VCP210708
Contributor
Contributor

Hello... I need to create some unattended installs for ESX 4.0 - I understand that this will be supported in v0.90 of your appliance.

When will this be released?

Many Thanks

0 Kudos
davismisbehavis
Enthusiast
Enthusiast

I though that this was already supported, V0.90 is out and there was a replacement file for the import of the Virtual Appliance. Although this then shows the EDA as V0.88 I have managed to do deployments of ESX 4.0 into a Virtual Machine on an ESX 4i host without issue.

I am working on a blog post and video of this but haven't had the time recently to complete it. I did post the video on youtube but was reworking it at a better resolution which I plan to have done next week.

The ESX host deployed OK, however I wasn't being to fussy about whether the post script worked exactly as expected.

Here is the not so good resolution video

0 Kudos
VCP210708
Contributor
Contributor

Hello,

Thanks for your response, I have had a look at the appliance and just getting my head round it...

I have some question and wondering if you can help? Is there a way to add firewall permissions i.e. Allow certain ports through both incoming and outgoing?

Is there also a way to activate Sudo and add permissions?

Many Thanks

Regards

Dean Moorcraft

0 Kudos
davismisbehavis
Enthusiast
Enthusiast

You can do all those kind of things in the post build configuration script. Here is an example of what I have in the EDA post build script window. This was for an ESX 3.5 U4 build

Within this you will see that I open up SMTP so I can send a health check report out after the build has been done, I then use the esxcfg-firewall -c command to close it off once complete. You just need to know the name of the services you want to enable or the numbers of the ports you want to open.

/usr/sbin/esxcfg-firewall -o 25,tcp,out,smtp_out

Not sure about the Sudo stuff, believe it's just a file that needs to be added to. If so you can take a back up and then append to a file like I've done with the resolv.conf file. Basically if you can do it at the command line you can do it using the EDA.

#DNS and Gateway

mv /etc/resolv.conf /etc/resolv.conf.old

echo "search virtualpro.local" >> /etc/resolv.conf

echo "nameserver 192.168.11.1" >> /etc/resolv.conf

echo "GATEWAY=192.168.11.1" >> /etc/sysconfig/network

Hope this helps somewhat

Regards

Davismisbehavis

0 Kudos
VCP210708
Contributor
Contributor

How are you getting on with the higher defination video?

0 Kudos
davismisbehavis
Enthusiast
Enthusiast

You mean for the EDA deployment video? if you do, the answer is slowly!

I've just rebuilt my main PC as windows 7 yesterday so getting everything re-installed. The VI Client and Camtasia Studio are on my list, once that's done I'll be looking to produce an improved video for posting on you tube. Will let you know when it's done.

0 Kudos
IMMatt
Enthusiast
Enthusiast

I'm looking for this release as well. The download link does not appear to work. I can't get to www.virtuall.eu at all. Anyone else have this appliance? Perhaps someone can create a sourceforge archive, assuming that everything within is GPL?

0 Kudos