billdossett
Enthusiast
Enthusiast

vsphere 6.7 U1A deploy Ubuntu 18 from template

Jump to solution

Hey, I've been trying to deploy from a Ubuntu18 template and it isn't working... 

I have read and implemented all the KBs

56409

59557

I am using cloudinit which I believe should work with this version of vsphere

As far as I can tell cloudinit is finished,  the logs in vmware-imc say that it has finished and handed off to cloudinit... but at the end of cloudinit it says ens160 is down.

When I look at the VM the network interface is disconnected, also the host name has not been changed.  I was working at another site that was only 6.5 which I think does not work with cloudinit.  I finally got rid of that baggage and now at the new site we are 6.7U21A and thought I could finally get this to work, but no.  I've pretty much run out of ideas to try as has google.  It wouldn't be a big deal, but we use a selfservice provisioning system and users do not have access to hardware to connect the NIC... so tickets get opened etc etc...

I don't want to have to rip out all the networking and go back to ifup/down, really seems to me that this should more or less work out of the box.

Regards

Bill

Bill Dossett VCP4, VCP5, VCAP-DCA 5, VCAP-DCD5 I'm amazed sheeps' clothing is even made in wolf sizes. That's just asking for trouble.
Tags (1)
0 Kudos
1 Solution

Accepted Solutions
billdossett
Enthusiast
Enthusiast

So I guess there is a problem with 6.7U21A and it still doesn't work with CloudInit.  I uninstalled Cloudinit and it went back to using the Perl workflow and all good now.

Same problem with UB 20 only worse....  had to change the /etc/issue file to be 18 instead of 20... then it also works with the old Perl workflow - basically Vsphere doesn't know anything about 20, so it doesn't match any of the version in the script and it just tries to do a generic which  fails.  I believe it is fixed in 6.7 Update 3...

Bill Dossett VCP4, VCP5, VCAP-DCA 5, VCAP-DCD5 I'm amazed sheeps' clothing is even made in wolf sizes. That's just asking for trouble.

View solution in original post

0 Kudos
1 Reply
billdossett
Enthusiast
Enthusiast

So I guess there is a problem with 6.7U21A and it still doesn't work with CloudInit.  I uninstalled Cloudinit and it went back to using the Perl workflow and all good now.

Same problem with UB 20 only worse....  had to change the /etc/issue file to be 18 instead of 20... then it also works with the old Perl workflow - basically Vsphere doesn't know anything about 20, so it doesn't match any of the version in the script and it just tries to do a generic which  fails.  I believe it is fixed in 6.7 Update 3...

Bill Dossett VCP4, VCP5, VCAP-DCA 5, VCAP-DCD5 I'm amazed sheeps' clothing is even made in wolf sizes. That's just asking for trouble.

View solution in original post

0 Kudos