Akide
Enthusiast
Enthusiast

vSphere 7 with k8s failed to enable

Jump to solution

pastedImage_1.pngpastedImage_3.png

Tags (2)
0 Kudos
1 Solution

Accepted Solutions
daphnissov
Immortal
Immortal

2020-07-01T17:47:32Z esxupdate: 3079151: imageprofile: INFO: Adding VIB VMware_bootbank_spherelet_1.0.2-16215255 to ImageProfile (Updated) DellEMC-ESXi-6.7U1-10764712-A04

The solution is called "vSphere 7 with Kubernetes" but you have ESXi 6.7 U1. You cannot run this solution with ESXi 6.7. Everything has to be at 7.0.

Cloud you please confirm that this issue is related to SSO domain.

No, I cannot, however this is a point of best practice. Don't change defaults if you don't know what they do.

View solution in original post

0 Kudos
11 Replies
Akide
Enthusiast
Enthusiast

pastedImage_0.png

0 Kudos
daphnissov
Immortal
Immortal

You've posted three screenshots and not a single word of text. Please read the first article in my signature if you want help.

0 Kudos
Akide
Enthusiast
Enthusiast

I have found some information may related to this issues from esxi hostd.log .

Hypervisor version :VMware ESXi, 7.0.0, 15843807  

vCenter version : 16386335

NSX-T version : 3.0.0.0.0.15946739

LOCAL\vpxd-extension-a1fa2a71-37b2-4e43-9cb1-c2e6f49651ca] Task Created : haTask--vim.vslm.host.CatalogSyncManager.queryCatalogChange-198105

2020-07-01T12:47:20.012Z info hostd[2102847] [Originator@6876 sub=Libs opID=sps-Main-558800-913-17-bb-599a user=vpxuser:VM.LOCAL\vpxd-extension-a1fa2a71-37b2-4e43-9cb1-c2e6f49651ca] (403)

2020-07-01T12:47:20.012Z info hostd[2102847] [Originator@6876 sub=Libs opID=sps-Main-558800-913-17-bb-599a user=vpxuser:VM.LOCAL\vpxd-extension-a1fa2a71-37b2-4e43-9cb1-c2e6f49651ca] New error before the previous is handled

2020-07-01T12:47:20.012Z info hostd[2102847] [Originator@6876 sub=Vimsvc.TaskManager opID=sps-Main-558800-913-17-bb-599a user=vpxuser:VM.LOCAL\vpxd-extension-a1fa2a71-37b2-4e43-9cb1-c2e6f49651ca] Task Completed : haTask--vim.vslm.host.CatalogSyncManager.queryCatalogChange-198105 Status success

0 Kudos
daphnissov
Immortal
Immortal

The hostd log is not going to contain anything valuable here. From a dcli session on the vCSA run vcenter namespacemanagement clustercompatibility list and post the output. Also look at the wcpsvc.log file at /var/logs/vmware/wcp for errors.

0 Kudos
Akide
Enthusiast
Enthusiast

Hi daphnissow

Thanks for your following up.

I have checked that vcenter namespacemanagement clustercompatibility list in dcli which shows following :

dcli> vcenter namespacemanagement clustercompatibility list                                           

|---------|----------|-----------------------|

|cluster  |compatible|incompatibility_reasons|

|---------|----------|-----------------------|

|domain-c8|True      |                       |

|---------|----------|-----------------------|

And wcpsvc.log attached below , any suggestions are appreciated.

0 Kudos
daphnissov
Immortal
Immortal

2020-07-01T09:12:28.176Z error wcp [opID=domain-c8-host-16] Failed to install vibs on host HostSystem:host-16. Err DependencyError: There was an error resolving dependencies. Code=14 Message=

Your host with moRefId of host-16 failed to install the Spherelet and other VIBs pushed out by the wcp service. Check esxupdate.log on this host for the reasons why. Possibly that host has no space available. From the logs, you're using a vm.local SSO domain, which means you've customized it from vsphere.local which you should not do unless you have a good reason. This could also cause failures. I would delete and redeploy this vCSA and do not alter the SSO domain name​.

0 Kudos
Akide
Enthusiast
Enthusiast

Appreciate for pointing that out, the esxupdate.log attached below.

Cloud you please confirm that this issue is related to SSO domain.

If do i will reorganize redeployment of VCSA as well.

Thanks again!

0 Kudos
daphnissov
Immortal
Immortal

2020-07-01T17:47:32Z esxupdate: 3079151: imageprofile: INFO: Adding VIB VMware_bootbank_spherelet_1.0.2-16215255 to ImageProfile (Updated) DellEMC-ESXi-6.7U1-10764712-A04

The solution is called "vSphere 7 with Kubernetes" but you have ESXi 6.7 U1. You cannot run this solution with ESXi 6.7. Everything has to be at 7.0.

Cloud you please confirm that this issue is related to SSO domain.

No, I cannot, however this is a point of best practice. Don't change defaults if you don't know what they do.

View solution in original post

0 Kudos
Akide
Enthusiast
Enthusiast

appropriate for pointing that out.

But there is the confused log representation which i have already update my ESXi to 7.0.0 version.

Why the log shows that esxupdate search package from DellEMC-ESXi-6.7U1-10764712-A04?

Could you please give me some suggestions to figure it out ?

pastedImage_0.png

0 Kudos
daphnissov
Immortal
Immortal

Not sure how you upgraded this host but it didn't change the image profile.

Also, the R720xd is not supported on anything past ESXi 6.5:

pastedImage_0.png

0 Kudos
Akide
Enthusiast
Enthusiast

Thanks for inform me that R720's compatibility and i have acknowledged that.

These hosts are just running as homelab so do not be surprised.

I will try to figure out how to change the profiles for these hosts and try again.

Anyway thanks for your support !

0 Kudos