touimet
Enthusiast
Enthusiast

vSphere 6.5 Host Profile vmk0 deleted -what gives?

Installed ESXi 6.5U1, moved to Distributed Switch, configured it as a reference host by adding couple vMotion vmkernels and couple iSCSI vmkernels, updated DNS and NTP setting.  So the vmkernels were laid out like this:

vmk0 = management

vmk1 = vmotion1

vmk2 = vmotion2

vkm3 = iSCSI1

vmk4 = iSCSI2

Then created a Host Profile. Updated that Host Profile with a MOTDm attached back to the original host and remediate.  Within a minute the host went disconnected and would not ping. Checked console and it was NOT rebooting.  So I performed a reboot on the host and it boot back up with vmotion1 IP address as the management IP.  WTH!!!

Manually changed the IP back to the management IP, re-connected to vCenter and now vmk0 is deleted and the management IP is on vmk1.   So it looks like this now:

vmk1 = management

vmk2 = vmotion2

vkm3 = iSCSI1

vmk4 = iSCSI2

Found these articles but were all dated for 5.x environments.

VMware Knowledge Base

Host profile removing vmk0 management port | vKARPS

Took a look at the vmk order in the Host Profile and the management vmk is listed first, see attached pic.  So clueless at this point.

Anyone experienced the same?

Tags (1)
9 Replies
jwininger
Enthusiast
Enthusiast

We had a similar issue with our 6.5 upgrade.  In our case, we had vmk0 for managment and vmk1 for vmotion.  Applying the host profile would just end up deleting vmk0 .  We ended up just manually configuring the networking on our hosts so that we could complete the upgrade.  I tried opening a support ticket, but they were clueless on the use of host profiles...so I just gave up.  What hardware are you using?  We use Cisco M4 blades.

The following link details the issue...but no resolution.

vSphere 6.5 + Host Profiles + vDS Networks

touimet
Enthusiast
Enthusiast

Thanks for the information.  I've never been a big fan of host profiles but figured I'd give it another go with all the changes in 6.5U1.  I never could understand why I needed to put a host into maintenance mode to simply update NTP settings or modify the MOTD when I can just run a PowerCLI script without maintenance mode of any hosts.  This latest effort at host profiles is not doing much to change my my long held view point on host profiles.  I WANT to be wrong what am I missing here???  Thx!

0 Kudos
karps
Contributor
Contributor

Hi,

I've had the same issue in the 6.5 environment I currently manage. I am not entirely sure why this occurs, but the workaround I found is this:

- Configure the VMKernel ports

- Update Host Profile Answer File

- Reboot the host ( Do not hit apply profile or remediate)

- When the host boots, it should apply the settings from the profile correctly and come back compliant.

Note, in this case we are using Autodeploy, but should apply to stateful builds too. I should update my blog post to include this!

0 Kudos
Martin_J
Contributor
Contributor

After a long long search I found out this problem, in our case, was caused by an override on the IP4 gateway of the vmk0 kernel port.

After removing the override, extract new profile it worked fine now.

klutch14u
Enthusiast
Enthusiast

Marin_J, can you elaborate a bit on  what you did to resolve and or where you found this?

iadz
Contributor
Contributor

Same issue with 6.7 U1. Uncheking "Default gateway - Override default gateway for this adapter" in vmk0 resolved it.

klutch14u
Enthusiast
Enthusiast

Here is the real "fix".  VMware Knowledge Base   PLEASE make sure you set it on ALL virtual nics, they use vmotion as the example but it has to be set on all of them.

VMware refuses to say this is workaround, option 2 (on the distributed switch) is the only thing that'd work for us.  The ridiculous part is after you modify the profile, apply it to a host and then update the profile from that same host it sets it all back.  So if you happen to update a profile from a host and forget to change it on the host profile manually, you destroy the networking on any host you apply it to.

0 Kudos
Hasewski
Contributor
Contributor

@iadz Thanks Dude. Spend half a day on this, and your solution worked for me also, Thanks heaps Smiley Happy

0 Kudos
maksh84
Contributor
Contributor

Thank buddy, It helped me too to get this issue resolved.

0 Kudos