ExpletiveDelete
Enthusiast
Enthusiast

vSAN Alert; NTP Not syncing ?

1. we have 6 hosts, a vcsa and external psc. All on 6.7.

2. we're using 3 NTP servers, a local gateway, time2.google.com & time3.google.com

3. we've bounced the NTP Services on the hosts with the scripts below:

Get-VMHost | Get-VmHostService | Where-Object {$_.key -eq "ntpd"} | Stop-VMHostService -Confirm:$false

Get-VMHost | Get-VmHostService | Where-Object {$_.key -eq "ntpd"} | Start-VMHostService -Confirm:$false

4. The vCenter and PSC have been set with the same NTP servers - an issue we're seeing is that no matter how we add them, it saves them as <gateway>, time3.google.com, time2.google.com

Time skew alerts on vSAN health.

5. We've even tried setting the vCenter and PSC to sync with the hosts (just to troubleshoot). No dice. same problem.

6. Time between hosts is less than 20 seconds.

foreach($esxcli in get-vmhost | get-esxcli){"" | select @{n='Time';e={$esxcli.system.time.get()}},@{n='hostname';e={$esxcli.system.hostname.get().hostname}} }

Time                 hostname    

----                 --------    

2018-08-13T19:04:28Z Host-05

2018-08-13T19:05:43Z Host-03

2018-08-13T19:05:44Z Host-01

2018-08-13T19:05:45Z Host-02

2018-08-13T19:04:31Z Host-06

2018-08-13T19:05:47Z Host-04

vCenter is set to Eastern, whereas the hosts only allow UTC. Per vSAN, the hosts are skewed by 1m 14s +/-

Does anyone have any idea how to get these synced? aside from silencing the alarm?

Tags (4)
0 Kudos
0 Replies