arzucore
Contributor
Contributor

vCenter Appliance 6.0 U3 - ESX Agent Manager (vmware-eam) service not starting

Jump to solution

Hi all,

I try to start vmware-eam service but I get the following error:

INFO:root:Service: vmware-eam, Action: start

Service: vmware-eam, Action: start

2019-01-10T08:59:59.182Z   Running command: ['/sbin/chkconfig', u'vmware-eam']

2019-01-10T08:59:59.245Z   Done running command

2019-01-10T08:59:59.245Z   Running command: ['/sbin/service', u'vmware-eam', 'status']

2019-01-10T08:59:59.402Z   Done running command

2019-01-10T08:59:59.403Z   Running command: ['/sbin/chkconfig', '--force', u'vmware-eam', 'on']

2019-01-10T08:59:59.480Z   Done running command

2019-01-10T08:59:59.480Z   Running command: ['/sbin/service', u'vmware-eam', 'start']

2019-01-10T09:00:04.384Z   Done running command

2019-01-10T09:00:04.384Z   Invoked command: ['/sbin/service', u'vmware-eam', 'start']

2019-01-10T09:00:04.384Z   RC = 1

Stdout = Starting VMware ESX Agent Manager...

Waiting for VMware ESX Agent Manager.......

WARNING: VMware ESX Agent Manager may have failed to start.

Last login: Thu Jan 10 08:01:28 UTC 2019

Stderr =

2019-01-10T09:00:04.384Z   {

    "resolution": null,

    "detail": [

        {

            "args": [

                "Command: ['/sbin/service', u'vmware-eam', 'start']\nStderr: "

            ],

            "id": "install.ciscommon.command.errinvoke",

            "localized": "An error occurred while invoking external command : 'Command: ['/sbin/service', u'vmware-eam', 'start']\nStderr: '",

            "translatable": "An error occurred while invoking external command : '%(0)s'"

        }

    ],

    "componentKey": null,

    "problemId": null

}

ERROR:root:Unable to start service vmware-eam, Exception: {

    "resolution": null,

    "detail": [

        {

            "args": [

                "vmware-eam"

            ],

            "id": "install.ciscommon.service.failstart",

            "localized": "An error occurred while starting service 'vmware-eam'",

            "translatable": "An error occurred while starting service '%(0)s'"

        }

    ],

    "componentKey": null,

    "problemId": null

}

Unable to start service vmware-eam, Exception: {

    "resolution": null,

    "detail": [

        {

            "args": [

                "vmware-eam"

            ],

            "id": "install.ciscommon.service.failstart",

            "localized": "An error occurred while starting service 'vmware-eam'",

            "translatable": "An error occurred while starting service '%(0)s'"

        }

    ],

    "componentKey": null,

    "problemId": null

}

Than I checked the eam.properties file. It was empty and I followed this article: VMware Knowledge Base

I have no whitespaces in eam.properties or other issues. Here is my eam.properties file:

#########################################################################

# Copyright 2013-2014 VMware, Inc. All rights reserved. VMware Confidential

#########################################################################

vc.proxy.host=localhost

vc.proxy.port=80

# Hostname or IP of the EAM server

# Fill only if EAM is not running on the same host as VC

eam.host=

# EAM service port used to configure the HTTP connector of the application server.

eam.int.http.port=15005

# Port and scheme configuration which is used by the ESX 6.x hosts to reach EAM Vib

# file server.

eam.ext.port=443

eam.ext.scheme=https

# Port and scheme configuration which is used by the ESX 5.x hosts to reach EAM Vib

# file server.

eam.ext.port.deprecated=80

eam.ext.scheme.deprecated=http

eam.support_linked_clone=true

eam.clear_db_on_startup=false

eam.debug_ref_count=false

eam.recent_event_size=20

# Enable/disable VUM integration

vum.integration=true

# Value is specified in minutes (set to 24h = 1440m)

eam.scan_for_unknown_agent_vms=1440

# The timeout to wait for hostd to restart on a host (set to 5m=300s)

eam.hostd_restart_timeout=300

# The following entries will be added verbatim to the advanced options

# of hosts on which EAM is enabled. All are optional.

Net.DVFilterBindIpAddress=169.254.0.1

Net.TrafficFilterIpAddress=

#The IP for the VSWIF NIC on the dvFilter switch (for ESX classic).

Net.DVFilterVswifIpAddress=169.254.0.2

# Resource bundle configuration

eam.resourcebundle.filename=eam-resourcebundle.jar

# VLSI embedded tcServer configuration

#

tcserver.tmp.dir=/var/tmp/vmware/eam/tomcat

# EAM SSL configuration

#

eam.keystore.type=VKS

eam.key.alias=vpxd-extension

eam.keystore.storename=vpxd-extension

# CM configuration

#

cm.url=http://localhost:18090/cm/sdk/?hostid=5e3bc8f2-af35-41bb-ae2d-1c11ad7f84e3

cm.wait.attempts=360

cm.wait.intervalSeconds=5

# SSO configuration

#

sso.wait.attempts=360

sso.wait.intervalSeconds=5

# VC SSL configuration

#

vc.truststore.type=VKS

vc.truststore.storename=TRUSTED_ROOTS

vc.tunnelSdkUri.template=https://##{VC_HOST_NAME}##:8089/sdk/vimService

vc.tunnelSdkUri=https://VCENTER44:8089/sdk/vimService

drs.demandCapacityRatio=100

If I try to start the service, I become the same error message like the empty file.

Here are the eam.log:

2019-01-10T09:00:00.970Z |  INFO | WrapperSimpleAppMain | Main.java | 47 | Initializing Spring from 'standalone.xml' and 'eam.properties'

2019-01-10T09:00:01.031Z |  INFO | WrapperSimpleAppMain | AbstractApplicationContext.java | 582 | Refreshing org.springframework.context.support.ClassPathXmlApplicationContext@43e7a657: startup date [Thu Jan 10 09:00:01 UTC 2019]; root of context hierarchy

2019-01-10T09:00:01.142Z |  INFO | WrapperSimpleAppMain | XmlBeanDefinitionReader.java | 317 | Loading XML bean definitions from class path resource [standalone.xml]

2019-01-10T09:00:01.267Z |  INFO | WrapperSimpleAppMain | XmlBeanDefinitionReader.java | 317 | Loading XML bean definitions from class path resource [eam-server-beans.xml]

2019-01-10T09:00:01.652Z |  INFO | WrapperSimpleAppMain | PropertiesLoaderSupport.java | 172 | Loading properties file from class path resource [eam.properties]

2019-01-10T09:00:01.663Z |  WARN | WrapperSimpleAppMain | AbstractApplicationContext.java | 550 | Exception encountered during context initialization - cancelling refresh attempt: org.springframework.beans.factory.BeanDefinitionStoreException: Invalid bean definition with name 'contentBase' defined in class path resource [standalone.xml]: Could not resolve placeholder 'eam.web.root' in string value "${eam.web.root}"; nested exception is java.lang.IllegalArgumentException: Could not resolve placeholder 'eam.web.root' in string value "${eam.web.root}"

Can someone help me?

Thank you!

0 Kudos
1 Solution

Accepted Solutions
arzucore
Contributor
Contributor

I've found the solution. I executed the Recreate_eam.propertiers.sh from VMware Knowledge Base

Now service is starting.

View solution in original post

0 Kudos
2 Replies
daphnissov
Immortal
Immortal

Open a support case with GSS on this.

0 Kudos
arzucore
Contributor
Contributor

I've found the solution. I executed the Recreate_eam.propertiers.sh from VMware Knowledge Base

Now service is starting.

View solution in original post

0 Kudos