mschenker
Contributor
Contributor

vCLS won't start

Jump to solution

While upgrading a 6.7 cluster (3 hosts w. VSAN) to 7.0U1 the vCLS system broke... at first the vCLS VMs migrated off the first to hosts and ended all on the last one on 6.7. Here they weren't able to move back to one of the 7.0U1 hosts, I shut them down manually in order to get the last host into Maintenance Mode. Upgraded that host to 7.0U1 as well and tried to reestablish the vCLS VMs. The VMs just won't start

No luck so far. Cluster was placed in "retreat" mode, all vCLS remains deleted from the VSAN storage.

When changing the value for "config.vcls.clusters.domain-c7.enabled" from "False" to "True", I'm seeing the spawing of a new vCLS VM in the VCLS folder but the start of this single VM fails with:

'Feature ‘bad_requirement.hv.capable’ was 0, but must be at least 1′. Failed to start the virtual machine. Module ‘FeatureCompatLate’ power on failed.

Nothing else... I can't find any pointers here... any ideas?! Only one vCLS is started, there should be three?!

Thanks for any hints!

Best, Martin

 

Tags (2)
0 Kudos
1 Solution

Accepted Solutions
depping
Leadership
Leadership

Just reading you post again, do you have vhv.enable = "TRUE" on your hosts in /etc/vmware/config by any chance?

View solution in original post

5 Replies
depping
Leadership
Leadership

Not sure this has anything to do with it, but can you check this blog post: http://www.yellow-bricks.com/2020/11/26/vcls-vms-not-powering-on-insufficient-resources-error/

 

Just noticed you left a comment on mu blog as well, somehow it escaped, hence the slow response.

0 Kudos
depping
Leadership
Leadership

Just reading you post again, do you have vhv.enable = "TRUE" on your hosts in /etc/vmware/config by any chance?

mschenker
Contributor
Contributor

HI Duncan!

Yes, this was set to TRUE.     

   ->  Should be FALSE.

This worked like a charm, after leaving the "retreat" mode all three vCLS are running fine, Cluster & DRS is healthy again! 

Just wondering were the "TRUE" entry is coming from... first time I looked at that config file. Cluster was delivered with 6.7  installed

Thanks again!

Best, Martin

0 Kudos
depping
Leadership
Leadership

this setting is usually used for nested virtualization, no clue why it was configured for you folks that way

0 Kudos
Srijithk
Enthusiast
Enthusiast

++ adding it to the discussion so that in case any one faces the same issue which might need vhv enabled

>> in case nested virtualization is needed for any of your application or software, for an example mcaffee needing it as per their docs https://docs.mcafee.com/bundle/advanced-threat-defense-4.4.0-installation-guide/page/GUID-479E14A0-5...

then enable it at VM level and disable it at the host level

you will then not have issues with vcls too, if not the workaround of @depping  of setting it up to false is good enough

Thanks,

Srijith

0 Kudos