Contributor
Contributor

unable to disable per-vm EVC

Recently I upgraded a test vm the hardware version to 14. I noticed that EVC was enabled for this vm. When I shutdown the vm and looked at the per-vm EVC setting, EVC was disabled. When I started the VM, EVC was enabled again.

EVC is disabled on host and cluster level. I also looked at the vmx file: evcCompatibilityMode = "FALSE".

I'm running vCenter on build number and ESXi build 6.7.0, 10302608.

How can I disable EVC for this vm?

0 Kudos
12 Replies

It is pretty easy to configure per-VM EVC from vSphere H5 client (flex client does not support).
Click on the VM >> Configure >> VMware EVC >>Edit >> Configure EVC mode.

VM must be powered off before configuring per-VM EVC

Blog: https://rickverstegen84.wordpress.com/ Twitter: https://twitter.com/verstegenrick
0 Kudos
Contributor
Contributor

Hi Rick,

that is the problem. When the vm is turned off the setting shows that EVC is disabled. When I turn the vm back on, EVC is enabled.

0 Kudos

Can you check the EVC mode of the VM by using EVC Mode column?

In the vSphere Client, select a cluster or a host in the inventory. lick the VMs tab. Click the arrow in any column title, select Show/Hide Columns, and select the EVC Mode check box.

Blog: https://rickverstegen84.wordpress.com/ Twitter: https://twitter.com/verstegenrick
0 Kudos
Contributor
Contributor

It states Ivy Bridge Generation just like the other vm's. Other vm's EVC is not enabled.

0 Kudos
Leadership
Leadership

... that is the problem. When the vm is turned off the setting shows that EVC is disabled. When I turn the vm back on, EVC is enabled. ...

What's the physical CPU model that's installed in the host on which you start the VM?

Does the EVC mode that shows up after powering on the VM correspond to the physical CPU's generation.

André

0 Kudos
Enthusiast
Enthusiast

I have exactly the same behaviour. Any resolution for this?

0 Kudos
Contributor
Contributor

Did anyone ever find a solution to this?

I'm hitting the same issue with a Win2k8R2 VM, HW version 15, on VMware ESXi, 6.7.0, 15160138

0 Kudos
Contributor
Contributor

Was this ever resolved?  I'm having the same issue with 6.7g.  The cluster has EVC disabled, I power the VM off, it show's EVC disabled on the VM.  As soon as I power the VM back up, it shows EVC being enabled on the VM only.  I've tried going into the settings of the VM and resetting the CPUID under CPU/Advanced but that doesn't resolve the issue.

0 Kudos
Leadership
Leadership

If the VM's EVC level corresponds with the physical CPU on which the VM has been powered on, then I wouldn't consider this being an issue.

André

0 Kudos
Contributor
Contributor

I have the same problem did you ever find a fix?

0 Kudos
Contributor
Contributor

Still waiting on a solution here.....

 

0 Kudos
Contributor
Contributor

I still have the same problem

0 Kudos