april14507
Enthusiast
Enthusiast

unable to delete virtual machine in esxi 6.5

I am trying to delete the existing virtual machine but the delete button is gray out.  The status for this vm as invalid. I guess that it is probably because I re-configure the array and I need to reinstall esxi. Is there another way to delete it?

P.S. after I reinstall esxi, I cannot see the local drive on the equipment. All I see is usb drive. I am thinking that the vm was not deleted earlier and the drive needs to format but I could not find anywhere to give me the option to format. I saw this issue in the past when I installed esxi on the existing esxi.

Please advise!

Tags (1)
0 Kudos
5 Replies
a_p_
Leadership
Leadership

... Is there another way to delete it?

Which ESXi 6.5 build do you use? Unless I'm mistaken the latest version of the ESXi Embedded Host Client allows deleting such obsolete entries from the inventory.

... after I reinstall esxi, I cannot see the local drive on the equipment.

What type/model of disk/RAID controller do you use? Is it on the official HCL, or did you install an additional driver for it?

André

0 Kudos
april14507
Enthusiast
Enthusiast

Which ESXi 6.5 build do I use?

Esxi 6.5.0 build number 5310538

What type/model of disk/RAID controller do you use? Is it on the official HCL, or did you install an additional driver for it?

It is HPE Proliant ML 350 Gen10. I configured it as RAID 5. It is on the official HCL. No, I did not install additional driver because they were used before and work before I re-configured the raid. I should have deleted the partition before doing re-configuration but I forget. 😞

0 Kudos
a_p_
Leadership
Leadership

Just to confirm, it's either a Smart Array P408i-a, or a HPE Smart Array E208i-a?

Reinstalling ESXi doesn't require to format the VMFS partition (dataastore). In fact, it allows to preserve the datastore in case a reinstallation is required.

Does the RAID5 volume show up in the Storage Adapter settings, or in the Add Storage wizard?

André.

0 Kudos
april14507
Enthusiast
Enthusiast

It is HPE smart array P408i-a SR Gen10.

I have reinstall esxi6u3 to overwrite 6.5 but when I logged in esxi from web browser, I am not able to see any local drives. During the installation, I did not see the option that local drives were listed except the internal USB where I installed esxi. The array has been configured array 5.

Please advise!

0 Kudos
a_p_
Leadership
Leadership

Can you confirm that you are using the HPE customizes ESXi images, which contain the required drivers for e.g. the RAID controller?

André

0 Kudos