VMware Cloud Community
khakisun
Contributor
Contributor

unabe to load the install program

微信图片_20210225175218.png

intall the esxi 7.0,stop when initialzing keyboard init

intall the esxi 6.7,stop when initialzing storage stack

cpu:3867u  

ram:8g ddr3l

msata:60g

Reply
0 Kudos
11 Replies
scott28tt
VMware Employee
VMware Employee

@khakisun 

How does your hardware (including storage adapters and network adapters) compare against the HCL?

https://www.vmware.com/resources/compatibility/search.php

 


-------------------------------------------------------------------------------------------------------------------------------------------------------------

Although I am a VMware employee I contribute to VMware Communities voluntarily (ie. not in any official capacity)
VMware Training & Certification blog
Reply
0 Kudos
khakisun
Contributor
Contributor

fixed it through using another msata ssd。

Reply
0 Kudos
mdebie
Contributor
Contributor

I have the same problem, I tried another MSATA but that didn't solve the problem.

Reply
0 Kudos
Sh3rl0ck
Contributor
Contributor

Did you solve the 6.7issue or the 7? I'm having the same InitVMKernel: keyboard_init error on a Gigabyte WRX80-SU8 with a AMD Ryzen TR PRO 3995WX

Reply
0 Kudos
techfreakj
Contributor
Contributor

Hi

I have exactly the same problem as this thread describes.

I have make a hundred of BIOS settings twekings but no luck on ESXi 7.0 U3 and also 6.7 15160138.
Mainly I focused to ESXi 7.0 because the hardware is very new (GIGABYTE WRX80 SU8 IPMI).

I have try some kernel boot options such as "jumpstart.disable=vmkusb", " preferVMklinux=TRUE", "noipmiEnabled", “ignoreHeadless=TRUE” (I am not sure if all this supported by vmkernel 7.0 because the are native ESXi drivers).

In contrast there is a confirmed success instaling ESXi 7 on "ASUS Pro WS WRX80E-SAGE SE" whitch is almost the same as Gigabyte except the Network Cards, the proof is here https://linustechtips.com/topic/1324316-vmware-and-threadripper-pro-3975wx-compatibility/?do=findCom...

I will appreciate any tip to bypass this obstacle.

Reply
0 Kudos
nachogonzalez
Commander
Commander

Hello, please check that all hardware (including nics, and storage controllers) are marked as compatbile on the VMware Compatibility matrix:

https://www.vmware.com/resources/compatibility/search.php


Reply
0 Kudos
techfreakj
Contributor
Contributor

Thank you for your suggestion but you are missing my point.
Hundreds of devices are not included in the white list and working out of the box.

Now for our case:
The AMD sWRX8 socket is a new AMD branch and there are few MOBOS in the market and less fewer use it as an ESXi platform.
The ASUS MOBO is working, the GIGABYTE is not working and the products are the same 99%. Check the specs to confirm.
I have open a ticket to GIGABYTE but I report also the bug here in VMWare because sooner or later someone will have the same problem or the solution 🙂 to the problem and also to help the developers to find a corner case.

Regards

Reply
0 Kudos
agallant_INO
Contributor
Contributor

Hi,

 

I have the same motherboard with a 3975wx, and I have the same issue during installation. It either gets stuck at Initializing initVMKernel: Keyboard_Init, or it PurpleScreens.

 

Very frustrating paying a lot of money, and it doesn't even installs. I had to install another hypervisor, it booted right up.

Reply
0 Kudos
techfreakj
Contributor
Contributor

Hello

I have good news, after contacting Gigabyte they have send me a new BIOS which is working.
I suppose they will publish it to their site after my positive feedback.
In any case I have attached also here.

Regards
Jason

Reply
0 Kudos
mvrk
Enthusiast
Enthusiast

And everything works on ESXi 7 with the Gigabyte WRX80-SU8-IPMI? Network cards? M.2 nvmes? SATA disks?
Reply
0 Kudos
techfreakj
Contributor
Contributor

Yes, even the PCI-X passthrough is working with an NVIDIA P1000 card.