ramses80
Contributor
Contributor

not sending ctrl+alt+del since ESXi-6.7.0-20190401001s-standard

Hi,

for testing i installed a fresh ESXi 6.7U2 on a host and was wondering why i cant send ctrl+alt+del to a  Windows server 2016 and Server 2019 installation.

After that, i install a fresh older ESXi (6.7U1) and tried it  again. It was working!

Now i started to install update by update.

ESXi-6.7.0-20181104001-standard - fine

ESXi-6.7.0-20190104001-standard - fine

ESXi-6.7.0-20190304001-standard - fine

ESXi-6.7.0-20190401001s-standard - sending ctrl+alt+del stopped working.

Finally i found out, it works if you use Microsoft Edge but not with Chrome or Firefox.

Anyone got an idea what that is? Didnt find anything about a bug like that.

24 Replies
ramses80
Contributor
Contributor

Just to let you know:
Seems to be a known bug

ESXi Embedded Host Client - Bugs

Salesianas
Contributor
Contributor

Thank you for the tip with MS Edge!!

You saved my life!

0 Kudos
Salesianas
Contributor
Contributor

It works in Opera Web Browser either.

:smileygrin:

0 Kudos
nob0dy
Contributor
Contributor

Not fixed in latest ESXi-6.7.0-20190404001-standard

04302019

0 Kudos
Thicot
Enthusiast
Enthusiast

It is a pity that Vmware Vsphere 6.7.0 Update 2 (Build 13006603) is not able to send the crucial CTR+ALT+DEL to open a Microsoft Windows session. I am using only Mac OS computers and I have to use Vmware Remote Crontrol or Vmware Fusion just to send this keystroke!! It does not work with Firefox 67.0.2 or the native Safari 12.1 or Chrome version 75 or Opera 60 on a Mac computer.

0 Kudos
Salesianas
Contributor
Contributor

Just click on the screen... problem solved.

0 Kudos
Thicot
Enthusiast
Enthusiast

What the hell are you talking about? This only works with Windows 10 desktop version, not a server.

Clicking on the screen does not send CTRL+ALT+DEL to unlock a Windows Server virtual machine.

0 Kudos
Salesianas
Contributor
Contributor

Come back to planet earth.

I'm talking about topic issue.

CTRL+ALT+DEL isn't working in ESXi 6.7 when opened in Google Chrome browser. In this case, click on black screen and will appear the user password's request.

Capturar.PNG

0 Kudos
Thicot
Enthusiast
Enthusiast

You must have ignored my precedent message, this does not work at all on a Mac computer whatever the web browser used: Safari, Chrome, Firefox, Opera or Edge for Mac Os.

0 Kudos
ashishsingh1508
Enthusiast
Enthusiast

Hi @ramses80

We have reported this internally.

This will be fixed in future release of 6.7.

Ashish Singh VCP-6.5, VCP-NV 6, VCIX-6,VCIX-6.5, vCAP-DCV, vCAP-DCD
Thicot
Enthusiast
Enthusiast

Thanks, any ETA for this fix?

0 Kudos
afiz_abdullah
Contributor
Contributor

Hi,

As a workaround for the time being, I disable Ctrl-Alt-Del in all Windows VM, using Registry Editor, via web ui + VMware remote console:

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\System

Set 'DisableCAD' to '1'

And reboot the VM

0 Kudos
vetman
Contributor
Contributor

Edge on Windows 10 (1903) does work for me where Chrome does not.

0 Kudos
ashishsingh1508
Enthusiast
Enthusiast

The fixed version will be released soon.

Ashish Singh VCP-6.5, VCP-NV 6, VCIX-6,VCIX-6.5, vCAP-DCV, vCAP-DCD
0 Kudos
starikm
Contributor
Contributor

Working with IE11 too.

repstein
Contributor
Contributor

FN + Control + Option + Delete worked for me in Mac OS Firefox and ESXI 6.7 Update 2 (Build 13006603).

Regards,

Randy Epstein

Thicot
Enthusiast
Enthusiast

Oh man, you got it!! I would never had thought about it, it also works with Safari!

0 Kudos
cristianvc
Contributor
Contributor

Hi,

I have same problem in Chrome but I've got it working on Edge.

Greetings

0 Kudos
Sugarman
Contributor
Contributor

Credit to /u/vertifly for posting this on Reddit - but you can do <ctrl><Windows-key><alt><delete> and it'll send the ctrl+alt+del command and unlock the VM in Chrome - good workaround until they fix it, but it's must faster than using the GUI anyway so i'll stick with this!