NSALAR1986
Contributor
Contributor

What is the list of Obsolete OS versions in ESXi.

Jump to solution

What is the list of Obsolete OS versions in ESXi?

Is ESXi version 5.5 u3 is an Obsolete OS version?

0 Kudos
1 Solution

Accepted Solutions
RvdNieuwendijk
Leadership
Leadership

I looked in the VMware Compatibility Guide and I found several Cisco UCS C M3S systems. For example, UCS - C22 M3S, UCS - C220 M3S Rack Server, UCS - C24 M3S, UCS - C240 M3S Rack Server. All of them are supported with ESXi releases up to 6.7. So, you can choose which ESXi version you want to upgrade to. Because ESXi 5.5 general support is almost ended, I would recommend you to upgrade to ESX 6.0 or a higher version. Take into consideration that end of general support for ESXi 6.0 will be at 2020/03/12. So, if you upgrade to ESXi 6.0, you will have to do another upgrade within one and a half year.

When you upgrade to ESXi 6.0 or higher, there are several decisions you have to make. For example, do you want to use the Windows-based vCenter Server or do you move to the vCenter Server Appliance (VCSA)? Do you use an internal or an external Platform Services Controller (PSC)? Read the release notes and the documentation before you upgrade and make your decision on the information you get. Besides, upgrade the firmware of the servers before you do an ESXi upgrade.

Blog: https://rvdnieuwendijk.com/ | Twitter: @rvdnieuwendijk | Author of: https://www.packtpub.com/virtualization-and-cloud/learning-powercli-second-edition

View solution in original post

0 Kudos
8 Replies
RvdNieuwendijk
Leadership
Leadership

I am not sure what your definition of obsolete is. According to the VMware Lifecycle Product Matrix, ESXi 5.5 end of general support is on 2018/09/19. For me, this would mean that ESXi 5.5 is obsolete.

Blog: https://rvdnieuwendijk.com/ | Twitter: @rvdnieuwendijk | Author of: https://www.packtpub.com/virtualization-and-cloud/learning-powercli-second-edition
0 Kudos
GayathriS
Expert
Expert

What exactly you mean by obsolete OS version ?

what do you want to know ?

0 Kudos
NSALAR1986
Contributor
Contributor

Thank you Robert for your valuable reply. Actually, our one of the customers is running ESXi version 5.1 and having some vulnerability issue (Obsolete OS). Could you please let us know in which ESXi version near to 5.1 we can fix this vulnerability issue.

0 Kudos
NSALAR1986
Contributor
Contributor

Actually, our one of the customers is running ESXi version 5.1 and having some vulnerability issue (Obsolete OS). Could you please let us know in which ESXi version near to 5.1 we can fix this vulnerability issue.

0 Kudos
RvdNieuwendijk
Leadership
Leadership

If you want to upgrade to a newer ESXi version, there are some more VMware documents you need to look at and take into consideration.

The VMware Compatibility Guide shows you if an ESXi version is supported on your hardware. If you have old hardware, a newer ESXi version might not be supported on the hardware.

The VMware Guest OS Compatibility shows if a guest operating system is supported on an ESXi version. For example, Windows Server 2016 is supported in ESXi 6.0 and higher versions.

If you are running other VMware products that rely on vSphere, the VMware Product Interoperability Matrices tells you which versions work together.

You need to study all of the above documents and the VMware Lifecycle Product Matrix to decide to which ESXi version you can and want to upgrade to.

Blog: https://rvdnieuwendijk.com/ | Twitter: @rvdnieuwendijk | Author of: https://www.packtpub.com/virtualization-and-cloud/learning-powercli-second-edition
0 Kudos
NSALAR1986
Contributor
Contributor

Thank you for your reply Robert, My query is that we have Cisco UCS C M3S hardware and ESXi 5.1 version is running on it. Now our customer has some issue regarding the vulnerability with Obsolete OS (vulnerability description "Extended support for all versions of VMWare ESX and ESXi Server prior to 5.5 has ended. Unsupported versions of ESX Server may contain unpatched security flaws. It is recommended to upgrade to a supported version."). Could you please suggest us the ESXi version near to 5.1 to remove this vulnerability issue.   

0 Kudos
RvdNieuwendijk
Leadership
Leadership

I looked in the VMware Compatibility Guide and I found several Cisco UCS C M3S systems. For example, UCS - C22 M3S, UCS - C220 M3S Rack Server, UCS - C24 M3S, UCS - C240 M3S Rack Server. All of them are supported with ESXi releases up to 6.7. So, you can choose which ESXi version you want to upgrade to. Because ESXi 5.5 general support is almost ended, I would recommend you to upgrade to ESX 6.0 or a higher version. Take into consideration that end of general support for ESXi 6.0 will be at 2020/03/12. So, if you upgrade to ESXi 6.0, you will have to do another upgrade within one and a half year.

When you upgrade to ESXi 6.0 or higher, there are several decisions you have to make. For example, do you want to use the Windows-based vCenter Server or do you move to the vCenter Server Appliance (VCSA)? Do you use an internal or an external Platform Services Controller (PSC)? Read the release notes and the documentation before you upgrade and make your decision on the information you get. Besides, upgrade the firmware of the servers before you do an ESXi upgrade.

Blog: https://rvdnieuwendijk.com/ | Twitter: @rvdnieuwendijk | Author of: https://www.packtpub.com/virtualization-and-cloud/learning-powercli-second-edition
0 Kudos
NSALAR1986
Contributor
Contributor

Thank you so much for your valuable comments Smiley Happy

0 Kudos