pahipo51
Contributor
Contributor

Vsphere Client for ESXi 6.5

Jump to solution

I have a standalone ESXi 6.5 host and I don't have a license for a vcenter server.  I there a way for me to manage the host other than using a web browser?

1 Solution

Accepted Solutions
bhards4
Hot Shot
Hot Shot

You, can use vSphere 6.0 client to access ESXi 6.5.

There are 2 ways to download the vSphere client.

1) Access the Existing ESXi 6.0 by browsing it from browser. From there you can download the vSphere client.

2) Download it from the link mentioned VMware Knowledge Base  to download vSphere leint C#.

-Sachin

View solution in original post

16 Replies
daphnissov
Immortal
Immortal

No, not from a GUI perspective anyway. The legacy C# client no longer functions as of the 6.5 release.

0 Kudos
bhards4
Hot Shot
Hot Shot

Hi,

Officially, vSphere client c# is not available for ESXi 6.5 and vCenter 6.5. However you can access ESXi 6.5 with legacy vSphere c#client unofficially as its not supported.

For more information please go through below KB.

VMware Knowledge Base

-Sachin

0 Kudos
daphnissov
Immortal
Immortal

That is until you update to U1 and then it will fail to connect entirely.

pahipo51
Contributor
Contributor

Sachin,

Where do I go to download legacy vshpere c# client?

Pahipo51

0 Kudos
a_p_
Leadership
Leadership

You can find the download links for the C# Clients at https://kb.vmware.com/s/article/2089791

André

0 Kudos
bhards4
Hot Shot
Hot Shot

You, can use vSphere 6.0 client to access ESXi 6.5.

There are 2 ways to download the vSphere client.

1) Access the Existing ESXi 6.0 by browsing it from browser. From there you can download the vSphere client.

2) Download it from the link mentioned VMware Knowledge Base  to download vSphere leint C#.

-Sachin

Mattai
Contributor
Contributor

Web interface does not have half of the functionality of the application.

Are you planning more functionality?

Export and import of machines does not work correctly

0 Kudos
daphnissov
Immortal
Immortal

You need to ensure you're running the latest embedded host client. VM exports to OVA are known to not be supported in 6.5. Read the release notes.

mperu99
Contributor
Contributor

accessing local 6.5 esxi web interface, does not present option to download client..  just a login prompt.

Tags (1)
0 Kudos
a_p_
Leadership
Leadership

@mperu99 

It your reply to this > 4 years old thread meant as a question, or an answer?

In case it's a question, then note that this is the expected behavior (see previous replies).

André

0 Kudos
mperu99
Contributor
Contributor

It was a question....  so if i cannot use the client how do I manage the VMs now.. NOT THE WEB INTERFACE!!!  i hate the web interface..most of the time it does not work, for example exporting VMS , downloads fail to export, uploading files to datastores fail at times.. I did not have this problem with the client. I am half tempted to just go back to 6.0 so i can have my client back.

0 Kudos
IRIX201110141
Champion
Champion

Youre a few years late to the party.

Regards,
Joerg

mperu99
Contributor
Contributor

And?

Look I don't have fancy new servers, I am lucky to have what I have, G5 with a MD1000 running through a PERC 6E card,
and I am just learning this, help is what I need not sarcasm

 

regards

 

0 Kudos
IRIX201110141
Champion
Champion

But there is no better answer.

The feature freeze for the old Windows C# vSphere Client war in 5.5. The introduction of the HostClient starts as a Fling (you should check if there is a newer version).
Later VMware ships the Hostclient together with ESXi as a replacement of the old vSphere Client. The vCenter comes with a flashed Based WebClient which later was replaced with a HTML5 which than was renamed to vSphere Client.

So... if you would spend 500 Bucks for a vSphere Essentials or going the VMUG Adv. road you have the option to deploy a VCSA 7.0u3 to get the latest WebGUI which is also able to manage your old 6.5 Host.

The extended support period of ESX 6.5/6.7 ends in October 2022.

IIRC you could manage a 6.5.0 or u1 with the old C# windows Client. Get it running on a modern windows maybe another challenge.

Regards,
Joerg

 

 

0 Kudos
mperu99
Contributor
Contributor

I originally got this G5 server with 6.0,. then after many hours of attempts i was able to  upgrade to 6.5.0 from a depot file using exscli command , the client was still working on 6.5,  I think my mistake was jumping from 6.5.0 directly to 6.5.0u2   as the windows client was still working on 6.5 and you say it still works on 6.5.0U1 , I should have not jumped to U2.   Currently have a windows 10 pro and a 2016 server running on 6.5.0U2 , Yes i wish i had $500 to spend. I dont.. I wish i had better servers, I dont. This is what I have for my personal lab, to learn on  I was lucky to get a G5 and a MD1000 with a perc6e card and cables donated to me so I am grateful for that. 

So it sounds like i need roll back or re-install to go back to 6.5.0 and update 1  if i want to be using the windows client. I got 10 and 2016 on 6.5u2 so I am going to say i can probably get them running on 6.5u1

Everyone I speak to says stay away from 7.x for now.. and besides it would not work on my hardware anyways.  so yes im stuck on 6.0/6.5 but I am ok with that as a learning tool its all i need for now. 

Someone suggested if i could find a OVF template of some vcenter server I could do it that way ..

but sounds like i will nee to roll it back.

0 Kudos
IRIX201110141
Champion
Champion

6.5.0u1 its just guessing... on 6.5.0 the old Client will work in some way for sure. Keep in mind that all new vSphere related features which comes out after 5.5 are not working in the old client.

I haven't say that you should install ESXi 7.x on your hold hardware. I have say that you need to install VCSA 7.x to get the new good working HTML5 vSphere Client to manage your old 6.5 Host.

And there is no need for "searching" something when you just can doewnload the 60 days Eval from vmware.com.

Regards,
Joerg

0 Kudos