Highlighted
Contributor
Contributor

Vmware vSpehere virtual machine memory change is not allowed

Jump to solution

Vmware vSphere virtual machine(windows 2016  memory change is not allowed) in one of the VM in our HP simplivity HPE.

Memory change of other VM's are allowed.I removed the VM from inventory and added it again but still it won't allow to change the memory.Please help.

0 Kudos
1 Solution

Accepted Solutions
Highlighted
Contributor
Contributor

I created new VM and later add the 2 existing HDD but while it boots for few second in windows but finally throws error in booting up the windows 2016 give us an option to continue, troubleshoot or power-off, so I power-off the VM & removed it from inventory.

I downloaded the original vmx file, changed the memory in the multiple of  4 MB, i.e: 64 GB & uploaded it again to datastore.

Boooted the system, now memory  reflecting  appropriately.

View solution in original post

0 Kudos
9 Replies
Highlighted
VMware Employee
VMware Employee

Are there any snapshots?

Are you suspending the VM instead of powering it off?

0 Kudos
Highlighted
Contributor
Contributor

Im powering off the VM & not suspending, its windows 2016 standard.Even I removed from the inventory & added it again but still it is not allwoing to edit the memory size, it does give the option in a dropdown list which is very high , I need to keep it to 32 GB , either it is allowing it to 4 GB or 512 GB memory.

0 Kudos
Highlighted
Contributor
Contributor

While VM is off it still hold 0 byte vmx.lck file which I tried to delete but it says cannot delete.

Can I just download the vmx file , change the mem size & uoload it again ???will it change the memory ??

0 Kudos
Highlighted
VMware Employee
VMware Employee

Moderator: Please do not start multiple threads on the same issue.

The additional thread you created today has been deleted.


Forum Usage Guidelines: https://communities.vmware.com/docs/DOC-12286
VMware Training & Certification blog: http://vmwaretraining.blogspot.com
0 Kudos
Highlighted
Contributor
Contributor

Update on this issue: Memory change is not allowing to edit the size of the memory but it does have the drop down list of memory with MB & GB selection & through that I can only have 4 GB or 512 GB or more , I cannot able to set this up to 32 GB. Please help

0 Kudos
Highlighted
Contributor
Contributor

I have attached the VM setting snapshot, the way memory drop down appears

0 Kudos
Highlighted
Enthusiast
Enthusiast

You can fix this my creating a new virtual machine with desired configuration of memory cpu and networking settings and add the existing disk and power on the vm

0 Kudos
Highlighted
Commander
Commander

If you change it carefully, yes you can download the .vmx file, edit it, and then upload and register the VM again with this new one. However be careful to don't make it corrupted while you modify it with editor.

I suggest to create another VM with whatever memory config you required, and add your existing VMDK files to the new VM. I think it's a safe way and easier to do before you try to change the .vmx file. 

Please mark my comment as the Correct Answer if this solution resolved your problem
0 Kudos
Highlighted
Contributor
Contributor

I created new VM and later add the 2 existing HDD but while it boots for few second in windows but finally throws error in booting up the windows 2016 give us an option to continue, troubleshoot or power-off, so I power-off the VM & removed it from inventory.

I downloaded the original vmx file, changed the memory in the multiple of  4 MB, i.e: 64 GB & uploaded it again to datastore.

Boooted the system, now memory  reflecting  appropriately.

View solution in original post

0 Kudos