AlessandroG72
Contributor
Contributor

Vcenter 6.7 Error when adding new hosts

Jump to solution

Hello all , i migrate the VM from a old Fujtusu blade to a new Lenovo blade (4 server with 2 cpu for each server).

The problem is that when i add "new" hosts to the custer, the procedure fails with the following error: A general runtime error occurred

after this messages

The certificate store of vCenter Server cannot verify the certificate.

The SHA1 thumbprint of the certificate is:
45:54:E5:E2:FD:4C:69:74:D4:2F:22:AA:67:23:A7:37:37:39:E0:B8

Click Yes to replace the host's certificate with a new certificate signed by the VMware Certificate Server and proceed with the workflow.

Click No to cancel connecting to the host.

Can we give me some advice ?  is very import that i finish migration before Monday.

0 Kudos
1 Solution

Accepted Solutions
daphnissov
Immortal
Immortal

Well, the error message is telling you what you nee to do. vCenter 6.7 cannot accept that SHA-1 certificate and it's asking if you want to generate a new one from the VMCA. Click yes to do so. Click no to replace the certificate manually.

View solution in original post

0 Kudos
14 Replies
daphnissov
Immortal
Immortal

Well, the error message is telling you what you nee to do. vCenter 6.7 cannot accept that SHA-1 certificate and it's asking if you want to generate a new one from the VMCA. Click yes to do so. Click no to replace the certificate manually.

View solution in original post

0 Kudos
MikeStoica
Expert
Expert

You just have to click yes so that host's certificate it will be replaced. After that all is good.

0 Kudos
EricChigoz
Enthusiast
Enthusiast

The certificate store of vCenter Server cannot verify the certificate.

The SHA1 thumbprint of the certificate is:
45:54:E5:E2:FD:4C:69:74:D4:2F:22:AA:67:23:A7:37:37:39:E0:B8

Click Yes to replace the host's certificate with a new certificate signed by the VMware Certificate Server and proceed with the workflow.

Click No to cancel connecting to the host.

Can we give me some advice ?  is very import that i finish migration
before Monday.

Find this helpful? Please award points. Thank you !
0 Kudos
MikeStoica
Expert
Expert

As I already said and daphnissov also, you can press yes and certificate will be replace and everything will go well.

0 Kudos
whodat
Contributor
Contributor

Hi,

As per your instruction, we have done this. But didn't fix the issue. Instead we face this. Any help?

DK

0 Kudos
davidg370
Contributor
Contributor

You are giving an answer that should work but it does not work. I was able to resolve the same issue by reverting to the Flash client. Sorry if the response was unpolite. The HTML5 client would not allow me to add the Host.

0 Kudos
scott28tt
VMware Employee
VMware Employee

Moderator: Please be careful with your language towards other users.

0 Kudos
davidg370
Contributor
Contributor

My apologies for a poor response. The solution for this issue is to use the Flash client.

AnthonyFogg
Contributor
Contributor

Just adding to this, I had this same issue and eventually had issues logging into the server even through direct connection using copy/paste passwords from a password manager. I eventually enabled the SSH to the server and suddenly the web interface on the ESXi server worked and I could add to vSphere using the same clipboard copy of the password.

Using vSphere Client version 6.7.0.42000 and VMware ESXi, 6.7.0, 14320388

Hope this helps someone else.

0 Kudos
kctbwa
Contributor
Contributor

I encountered the same issue. In addition, if not using the flash client, will NOT be able to select the license.

6.5.0 Update 3 (Build 14990892)

0 Kudos
elsitamx
Contributor
Contributor

I am getting the same error while using HTML with vSphere Client version 7.0.1.00000

I don't have the option to use Flash anymore as we recently upgraded Vcenter. 

 

 

0 Kudos
MercuriConf
Contributor
Contributor

Check in the esxi interface local to the machine and confirm that Lockdown Mode is disabled. 

0 Kudos
mshaker1880
Contributor
Contributor

in vCenter 7.1 now , fixed the issue via adding the host to the Datacenter directly instead of adding the Host to the Cluster

. Find this helpful? Please award points. Thank you ! http://www.mosab-shaker.com/author/mosap8moh/

Find this helpful? Please award points. Thank you !
http://www.mosab-shaker.com
Tags (1)
0 Kudos
williamzillger
Contributor
Contributor

it has NOTHING to do with lock down mode

get back into the console, yellow screen, and restart the management agent 

that will allow you to move forward and add host

0 Kudos