Mgrab
Contributor
Contributor

VMTools Mouse "Driver" Stops Working

So, I've been using ESXi and vSphere for a while now and when I run into an issue I can usually find an answer or solution relatively quickly, but I'm floundering with this one.

I have one particular Windows 10 VM (that I just rebuilt and it's still doing the same thing) where after the VM sits idle for a period of time it's as if the VMTools mouse driver stops working and the mouse starts acting all janky and gets trapped in the console window as if VMTools isn't installed. I've tried restarting the service to no effect. I wound up rebuilding the VM and it's still doing the same thing. The only thing that fixes it seems to be rebooting the machine. Searching around all I seem to find is people recommending installing VMTools, but I can't seem to find any threads where someone has had an issue quite like this, or I just don't know the right keywords to search for.

My guess is, since I seem to only be seeing this on one VM (at least, that I'm aware of) it could potentially be related to the software I'm running on it. But I've run this exact software on other Windows VMs in the past without issue. So I'm a bit confused here as to what might be going on.

Any help or suggestions in troubleshooting this would be greatly appreciated

Thanks for any responses.

Mike

6 Replies
Mgrab
Contributor
Contributor

I just realized, this only seems to apply to the remote console, I just came across another post that appears to mention an at least somewhat simllar sounding issue with the remote console. Using web console does not seem to produce the same issue.

0 Kudos
lucasbernadsky
Hot Shot
Hot Shot

Hi there! Maybe reinstalling VMRC? Have you tried using VMRC from another PC to discard a guest OS problem?

Mgrab
Contributor
Contributor

Well I don't see the same issue using Remote Console from this same laptop to other VMs, so I hadn't considered re-installing that.

I also just noticed the default power settings were on 'Balanced' and it looks like it was putting the computer to sleep, and I feel like that's when the mouse would start acting up. Still seems weird that it would be all janky in the remote console but not anywhere else, but I don't know exactly how VMTools works.

Thanks for the suggestion though.

0 Kudos
nachogonzalez
Expert
Expert

If you accept a suggestion, I would recommend running this fling on the VM (even it is not a VDI) VMware OS Optimization Tool | VMware Flings

It is not ideal to have power settings on the guest os since it has caused issues on the past.

Also, as lucas said VMRC reinstallation might solve the issue

Warm regards

Mgrab
Contributor
Contributor

Thanks for the reply, I just recently came across something mentioning that optimization tool and was thinking of looking into that more. Wasn't sure if it was ok to use on any VM or just within 'Horizons'? I'm not really familiar with that product at all.

I may give that a go as well. So far, after changing the power settings, I haven't seen the issue yet. So maybe that's all it was possibly.

0 Kudos
nachogonzalez
Expert
Expert

Horizon is a VDI solution, think of it as citrix.
Even if it is designed for VDI it will work by optimizing the resources

0 Kudos