ToniSAT
Enthusiast
Enthusiast

VCSA 6.5 Cluster settings

Hi,

we have following situation:

New vsca 6.5 installation with 10 Hosts (6.5, 5969303) attached to.

- EVC Mode Intel Westmere Generation enabled

- DRS enabled and "Automation Level" set to "Manual"

- vSphere HA enabled

By starting a powered off VM, only one Host is displayed in the Power On recommendations.

In my old vCenter 6 environment all hosts have been shown.

Any suggestion would be appreciated.

Best Regards!

VMware_Power_On_recommendation.jpg

8 Replies
schepp
Leadership
Leadership

Hi,

what's the point of showing all hosts? DRS should pick the best suited host for the VM and present this selection to you, as you selected manual mode.

There were quite some changes with DRS in vSphere 6.5. So I guess this is one of them.

Best Regards

0 Kudos
ToniSAT
Enthusiast
Enthusiast

Hi Tim,

thanks for your answer.

That's just what I was thinking.

The problem is that DRS is only showing Host "5" as recommendation. And Host "5" is neither in CPU nor in RAM the best choice.

Cluster_Ressources.jpg

0 Kudos
Aviator20111014
Enthusiast
Enthusiast

Hi,

if DRS ist set to "Manual" for initial placement the (one) recommended host is displayed. See VMware Docs: Edit Cluster Settings

The host recommendation depends on your DRS settings and might be host with seemingly high CPU and memory usage as well.

Cheers

David

0 Kudos
welder314
Enthusiast
Enthusiast

Did you ever find an answer to this?  I had VCSA 6.5 with ESXi 6.0 hosts.  Like you, when I powered on a guest, I was offered all available hosts.  Then I upgraded ESXi to 6.5 (VCSA not changed) and now when I power on a guest I only get one recommended host - no choice.  And I also see that DRS chooses an already overloaded host.  It's definitely not working the way it should.

0 Kudos
msripada
Virtuoso
Virtuoso

were you able to migrate the vms to other esxi hosts in the environment?

It looks like most of the vms are taking host 5 as best choice (which is not true) or VMs cannot migrate to other esxi hosts due to drs rule?

Thanks,

MS

0 Kudos
ToniSAT
Enthusiast
Enthusiast

welder314

No, nerver found a solution. Was told by VMware to open a Feature Request.

The described Power On behavior is "as designed" in the new 6.5 release.

see the VMware answer below:

"Regarding your case, in 6.5 DRS presents only one host in manual mode. In the previus versions, 5.5 and 6.0, DRS was presenting more than one host as a recommendation.
  So if you want to use another host you need then to migrate the vm and then power it on. "

msripada

All HA and DRS features are working including migrating VM's to other hosts.

0 Kudos
welder314
Enthusiast
Enthusiast

I had an open case with VMware about an issue with our 6.0 > 6.5 upgrade, and inquired about this behavior.  They provided an answer which looks to be the solution.

In the web client, Configure tab, Services, vSphere DRS:  In the Advanced Options / Configuration Parameters section, add these two parameters.

Option: FastInitPlace

Value: 0

Option: NetworkAwareDrs

Value: 0

Change is immediate, no further action required.

This restores the DRS behavior to that of the previous versions.

Now when I power on VMs, I see offers for all available hosts.

cbmadmin
Contributor
Contributor

Thanks welder314,

I had the same issue with our new vSphere 6.5 VCSA cluster.  Using your suggestion:

Option: FastInitPlace = 0

Option: NetworkAwareDrs = 0

fixed it immediately for me as well.  We only have 3 ESXi hosts, so I like the flexibility of picking and choosing which host to Power On a VM on.

0 Kudos