VMware Cloud Community
MatejSur
Contributor
Contributor
Jump to solution

Unable to set EVC mode

Hi guys,

I need your help with EVC settings. We have 3 host cluster with Intel Xeon Silver 4114 CPUs (Skylake). Now we need to add to the cluster two new hosts with Intel Xeon Silver 4210 CPUs (Cascade Lake). Before adding the new hosts I wanted to turn on EVC with Skylake compatibility but I get message "The host cannot be admitted to the cluster's current Enhanced vMotion Compatibility mode. Powered-on or suspended virtual machines on the host may be using CPU features hidden by that mode." whatever the setting is (I have tried to set all the listed CPU generations). Thanks for your tips in advance.

Reply
0 Kudos
1 Solution

Accepted Solutions
a_p_
Leadership
Leadership
Jump to solution

You are likely hit by an issue that is described in KB https://kb.vmware.com/s/article/76155 and you may unfortunately need to power-cycle (power-off, power-on) VMs which have not been power-cycled since an upgrade to the mentioned ESXi versions in the article's resolution section.

André

View solution in original post

6 Replies
a_p_
Leadership
Leadership
Jump to solution

You are likely hit by an issue that is described in KB https://kb.vmware.com/s/article/76155 and you may unfortunately need to power-cycle (power-off, power-on) VMs which have not been power-cycled since an upgrade to the mentioned ESXi versions in the article's resolution section.

André

Sachchidanand
Expert
Expert
Jump to solution

There is already a solved post on the said topic. Please see if it helps solving your issue:

https://communities.vmware.com/t5/VMware-vSphere-Discussions/Can-t-enable-EVC-mode/td-p/2275690

Regards,

Sachchidanand

BivasM
Enthusiast
Enthusiast
Jump to solution

EVC depends on the cpu features of the processor. if you have vm's that are already running with higher cpu features ... you can not enable EVC on that cluster with new hosts which have lower cpu features. Since skylake is lower your evc mode should be skylake 

https://kb.vmware.com/s/article/1005764

As far as i know you need to turn off the vm's which are running of cascade lake features. enable evc with skylake and turn the vm's back on. Provided getting a down time is not an issue ...

MatejSur
Contributor
Contributor
Jump to solution

Power-cycle of VMs resolved that issue. Thanks a lot! 

Reply
0 Kudos
MatejSur
Contributor
Contributor
Jump to solution

Power off VMs > Enable EVC > Power On VMs. Thanks a lot!

Reply
0 Kudos
MatejSur
Contributor
Contributor
Jump to solution

Power off VMs > Enable EVC > Power On VMs. Thanks!

Reply
0 Kudos