MattGoddard
Enthusiast
Enthusiast

Unable to join vCenter 7 to Active Directory domain

Jump to solution

I have a Server 2019-based Active Directory domain and I've just deployed vCenter 7 U2. Deployment was trouble free. However, I'm unable to join vCenter to the domain via Menu -> Administration -> Single Sign-On -> Configuration -> Identity Provider -> Active Directory Domain.

I'm filling out the dialog with the domain, leaving the OU blank, entering domain admin credentials in the format '[user]@[domain]' and then that user's password. But when I click 'JOIN', it immediately fails with this error:

Error trying to join AD, error code [31]

I have vCenter added statically in DNS (forward and reverse) and it's resolvable. All relevant ports are open on both domain controllers as far as I can tell. If I deliberately mess up the password then the error changes to, "The value provided as the current password is incorrect", implying that it's successfully validating those credentials against the domain. I've rebooted vCenter. And finally, I've googled the hell out of that error code.

What else could it be?

Labels (2)
0 Kudos
1 Solution

Accepted Solutions
MattGoddard
Enthusiast
Enthusiast

I was unable to find any solution to this. However, I read that integrated AD connectivity is now deprecated. So instead I tried the AD over LDAP method, which worked fine.

View solution in original post

0 Kudos
2 Replies
msripada
Virtuoso
Virtuoso

check /var/log/vmware/messages.log after reproducing the issue.

ensure time is sync with AD

 

 

0 Kudos
MattGoddard
Enthusiast
Enthusiast

I was unable to find any solution to this. However, I read that integrated AD connectivity is now deprecated. So instead I tried the AD over LDAP method, which worked fine.

View solution in original post

0 Kudos