Unable to copy, move or delete vmdk files - error "was initiated from h5-client/6.5.0@"

I hope someone can help.

We've started to see a failure in moving/copying/deleting VMDKs. Only on some datastores. Each time we try it fails with: error "was initiated from h5-client/6.5.0@ and completed with status Failure"

It was taking 30 minutes for the failure to happen but after rescanning the datastores the error is now instant.

I've checked this forum for the same error but only one post is shown without a resolution.

Has anyone seen this before and has a fix ?

Further info - we recently updated from VSphere 6.0 to 6.7,  everything worked fine before the upgrade

0 Kudos
1 Reply

Please be more precise: what vmdk-type are you talking about ?
A descriptor vmdk, a flat.vmdk, a delta.vmdk, a sesparse-vmdk, a ctk-vmdk or a RDM-vmdk ?

Typical reason for a non cooperative vmdk-files are either I/O errors or bad descriptor.
To find out which option applies run
hexdump -C <full path to vmdk-file> | less

You either get a hexdump view, a message with I/O error or a message with bad descriptor.

To deal with a non-deleteable large vmdk-file you resize io almost zero-size withh dd and afterwards wipe the associated inode.
Not ideal and not documented but way better than living with the wasted space.

To deal with a non readable vmdk with the intention to copy or move it somewhere you typically need the help of a Linux-VM

In real life dealing with non-cooperative vmdks you never need a move operation.

If you want a useful suggestion I need a vmfs-header-dump and a screenshot of the results of the already mentioned hexdump-test.




Do you need support with a recovery problem ? - send a message via skype "sanbarrow"
Tags (1)