kaissa
Contributor
Contributor

Unable to connect to the management interface (port : 5480)

I can not connect to the Appliance interface (Version 6.5)  using root/password credentials knowing that I can connect directly via ssh without any problem.

in the log file we found the message bellow :

51728]ERROR:root:Structure('LocalizableMessage', dict(defaultMessage='The maximum number of sessions has been reached', args=[]om.vmware.applmgmt.admind.authenticate.max.session'))

According to the error message, It seems that we have reached a maximum number of sessions on the interface of the Appliance, is this the case? if so, how can this number be reset?

We have tried the following procedure without success: delete and recreate the derectory :/etc/applmgmt/appliance/session/, stop and restart the service: vami-lighttpd

Any  idea please ?? thinks in advance.

Tags (1)
0 Kudos
10 Replies
daphnissov
Immortal
Immortal

If you run netstat -an | grep 5480 in an SSH session on the appliance, does it return a ton of entries in the ESTABLISHED state?

0 Kudos
kaissa
Contributor
Contributor

Think you daphnissovfor your response;

The port is in listening stat but no ESTABLISHED connection, the only output is in the folloing :

netstat -an | grep 5480

tcp6       0      0 :::5480                 :::*                    LISTEN

0 Kudos
daphnissov
Immortal
Immortal

That's strange, though. You're only showing an open socket on IPv6. Do you have IPv4 turned off somehow?? This may explain your issue.

0 Kudos
kaissa
Contributor
Contributor

We did not disable ipv4 anywhere, we have the same configuration on another site that works properly.

I have the same result if I execute the command  on another site that works properly.

# netstat -anp |grep 5480

tcp6       0 0 :::5480 :::*                    LISTEN      1291/vami-lighttpd

0 Kudos
msripada
Virtuoso
Virtuoso

Can you stop and start the service service vami-lighttp stop and service vami-lighttp start

0 Kudos
kaissa
Contributor
Contributor

We have already done this action and it has not solved the problem.

every time we try to connect we will get the error: "Authentication impossible, try again".

0 Kudos
mduregon
Contributor
Contributor

just got out from a support session with VMware.

They have an internal kb article about it and the fix is very simple (move bogus web session aside and try again). I asked them to publish fix to external KB

0 Kudos
lnxlrn
Contributor
Contributor

Um...what does "(move bogus web session aside and try again)" mean?  What is the very simple fix?  I've been working on this issue for 3 days now.

0 Kudos
rohi38rtt
Contributor
Contributor

Any Resolution for this issue ??

0 Kudos
msripada
Virtuoso
Virtuoso

Ensure vcenter/psc is snapshot and backedup

remove files under /var/vmware/applmgmt/sessions folder

Thanks,

MS