TECH198
Hot Shot
Hot Shot

TLS 1.0 how to enable

StorageCraft Support Community

Enable or Disable TLS Versions on vCenter Server Systems

I'm tying to enable TLS 1.0 on ESXI 6.7, as it seems there some incompatibility going on.   How can I enable TLS 1.0 *without* vCenter ?

Running stand-alone ESXi 6.7 host  on VMWare Fusion on Mac.

Tags (1)
0 Kudos
4 Replies
TECH198
Hot Shot
Hot Shot

I should have noticed the section on the near the bottom of the page:

However my output is as follows:

[root@localhost:~] reconfigueEsx ESXiHost -h 192.168.117.182 -u root -p TLSv1.0

-sh: reconfigueEsx: not found

[root@localhost:~]

As i just need TLS 1.0 enabled. Is there a command i'm missing, or changed?

0 Kudos
emvic86
Contributor
Contributor

Hi ,

Kindly check the below link

Enable or Disable TLS Versions on ESXi Hosts

0 Kudos
TECH198
Hot Shot
Hot Shot

opps. i forgot to post the link.. Ya,, I already did that got an "command not found".

0 Kudos
cjscol
Expert
Expert

The reconfigueEsx command comes as part of vCenter. Without vCenter you could try this on your ESXi host

Go to the /etc/vmware/rhttpproxy directory and edit the config.xml file, e.g.

vi /etc/vmware/rhttpproxy/config.xml

In the <ssl> section include TLS1.0 in <protocols>, e.g.

<protocols>tls1.0,tls1.1,tls1.2</protocols>

Make sure the line is not commented out, i.e. it does not have <!-- before it and --> after it like this

<!-- <protocols>tls1.0,tls1.1,tls1.2</protocols> -->

Restart the rhttpproxy with

/etc/init.d/rhttpproxy restart

Calvin Scoltock VCP 2.5, 3.5, 4, 5 & 6 VCAP5-DCD VCAP5-DCA http://pelicanohintsandtips.wordpress.com/blog LinkedIn: https://www.linkedin.com/in/cscoltock
0 Kudos