VMware Cloud Community
gciscol
Enthusiast
Enthusiast

Storage is lost in ESXi

Hi Please see the below. The USB-Storage is lost. The capacity of the original storage is 2TB, now its 0. During I installed Windows 10 as a VM, the process suddently stoped and then I noticed the capacity is lost. I did not make any change on ESXi, I rebooted ESXi, but it cannot resolve the issue. Anyone can help to provide suggestion? Thank you very much!

 

gciscol_0-1682132147192.png

 

Reply
0 Kudos
2 Replies
PatrickDLong
Enthusiast
Enthusiast

Is usbarbitrator running?  /etc/init.d/usbarbitrator status

This service should be disabled if you are using USB storage as a datastore.

#stop the service if running

/etc/init.d/usbarbitrator stop

Disable the service from running on startup:

chkconfig usbarbitrator off

then reboot and see if the storage is detected.  If not, you you can try to rescan for the storage by issuing:  esxcfg-rescan -d vmhba32    a few times until it completes without error, then issue  esxcfg-rescan -a vmhba32   .

What version and build of ESXi are you running, and is this an external USB-connected disk device, or a USB stick?  Lastly, as I'm sure you already know, VMFS on USB is NOT officially supported by VMware. although it is not an uncommon practice.  Never, ever do this in production or with data you cannot afford to lose 😉

 

Reply
0 Kudos
gciscol
Enthusiast
Enthusiast

Thanks for your reply! I thought it might be usb connection issue. so before you replied my post, i just unplug the usb and plug into the same port, then I got the below status. Now i even cannot access it via https and ssh except ping. Looks like the system broken. Why it happen? 

 

gciscol_0-1682172340838.png

 

Reply
0 Kudos