tom1955
Contributor
Contributor

Snapshot not being removed after Veeam Backup job

Vmware 6.7

Veeam Backup & Replication 9.5 Update 4

We have several VM's Windows Servers 2016 2019 2012 R2 that the snapshot is not removed at the end  of the backup job.

 

When Veeam Backup runs a backup job it first makes a temporary snapshot of the VM.  Then after all processing of the backup for that VM it will then delete the temporary snapshot.

I have over 150 Window Server VM's and all are backed up using Veeam B&R  

 

This issue is happening and several of the VM's 

 

I have to manually remove the snapshots 

 

I spoke with Veeam support and they suggest contacting VMware to help troubleshoot this.

Looking for some help on where to start looking 

 

Thank you

 

Tom

 

 

0 Kudos
2 Replies
Jimmy15
Enthusiast
Enthusiast

hi,

Please check with Backup team if backups are completed successfully.

Is Veem triggering remove snapshot call?

Any similarity in failed to remove snapshots VMs (ie VMware tools , exceptionally bulky VMs, vmNic etc)

Make sure all VSS writers are good in shape.

are you using dedicated nic of backup.

are these sharing same datastore.

there could be many reasons..

Regards


regards



PS: Mark kudos or correct answer as appropriate 🙂
0 Kudos
Jimmy15
Enthusiast
Enthusiast

...also check backup window and corresponding scheduled task in OS at the same time...

answers of above will give you idea to optimize backup jobs and infrastructure.

Hope this will help 🙂

regards


regards



PS: Mark kudos or correct answer as appropriate 🙂
0 Kudos