HunvHunvHunv
Contributor
Contributor

Set Config.HostAgent.plugins.solo.enableMob via Host Profile to false

Jump to solution

Hi,

currently I am trying to set the advanced configuration option "Config.HostAgent.plugins.solo.enableMob" to "false" using a host profile. I configured the host profile like this:

pastedImage_0.png

and checked the compliance of a ESXi host the profile is attached to. The strange thing is, that the ESXi Host says, that the profile value is "true" instead if the configured "false". Due to that the host profile is not compliant.

pastedImage_1.png

If I apply the profile, the setting will be set to "true". So this is not just a display error.

Anyone has ideas how to solve this?

0 Kudos
1 Solution

Accepted Solutions
jburen
Expert
Expert

IT Security.... I should have known 😉

So now you used the setting Configure a fixed option, right. Because Config.HostAgent.plugins.solo.enableMob is a boolean setting, changing it from the default will always set it to true. So try the setting "Set the option to its default value". This way you know that if the server is compliant the setting must be false because that is the default. If the server is not compliant the setting must be true... This should satisfy the security police.

Consider giving Kudos if you think my response helped you in any way.

View solution in original post

3 Replies
jburen
Expert
Expert

First things first... Why do you want to disable something that is already disabled? If your goal is to enable the MOB you must change the advanced option to true.

Consider giving Kudos if you think my response helped you in any way.
0 Kudos
HunvHunvHunv
Contributor
Contributor

Hi jburen,

good point, that was also my argument. The problem is, that the IT Security wants to be sure, that this setting is "false" and not by accident or somehow else set to "true". The easiest way is to do it using the host profiles like I want to do it. The alternative way would be a PS-Script that is checking this. But I like to use the host profile for this because this is the easier way...

0 Kudos
jburen
Expert
Expert

IT Security.... I should have known 😉

So now you used the setting Configure a fixed option, right. Because Config.HostAgent.plugins.solo.enableMob is a boolean setting, changing it from the default will always set it to true. So try the setting "Set the option to its default value". This way you know that if the server is compliant the setting must be false because that is the default. If the server is not compliant the setting must be true... This should satisfy the security police.

Consider giving Kudos if you think my response helped you in any way.

View solution in original post