Highlighted
Contributor
Contributor

Removing 'HD Audio' from VM

Jump to solution

Hi

I have recieved a VM running some sensitive software (changes to MAC-addresse, IP-address, Windows settings is not good).

The VM was originally created on VMware Workstation Smiley Sad and then imported into an 6.x ESXi/vCenter environment (now running 6.7).

vSphere is now complaining when trying to migrate - "Virtual Machine is configured to use a device that prevents the operation: Device 'HD Audio'...

I want to remove the device but the 'HD Audio' device cannot be removed under VM Settings (since its not supported on vSphere).

I have read that you can delete it directly from the .vmx-file by removing:

sound.autoDetect = "TRUE"

sound.virtualDev = "hdaudio"

sound.fileName = "-1"

sound.present = "TRUE"

sound.pciSlotNumber = "35"

Now for my question: can I just shut down the VM, connect to ESXi-host via SSH and edit the .vmx-file, and then it wil apply at power-on?

Or do I have to first unregister the VM from the inventory and then subsequently re-register it? (and will this operation make canges to MAC-address etc.?!?).

Regards,

Soren

1 Solution

Accepted Solutions
Highlighted
Contributor
Contributor

I went on and tried..

  • Snapshot VM and check that our Veeam has a copy of the VM (in case of emergency).
  • Shutdown VM.
  • SSH to the ESXi-host.
  • Remove audio-device from .vmx-file:
    • vi <path-to-vm>\VMname.vmx
    • Delete lines:
      • sound.autoDetect = "TRUE"

      • sound.virtualDev = "hdaudio"

      • sound.fileName = "-1"

      • sound.present = "TRUE"

      • sound.pciSlotNumber = "35"

  • Find the Vmid for the affected VM:
    • vim-cmd vmsvc/getallvms
  • Reload configuration for the VM:
    • vim-cmd vmsvc/reload <Vmid-of-VM>
  • Done!

Refresh your vCenter (or log out/in) and confirm that the device is now missing from the VM's settings.

Start the VM and confirm that everything is working properly.

I used following articles:

VMware Knowledge Base

VMware Knowledge Base

View solution in original post

0 Kudos
7 Replies
Highlighted
Contributor
Contributor

I went on and tried..

  • Snapshot VM and check that our Veeam has a copy of the VM (in case of emergency).
  • Shutdown VM.
  • SSH to the ESXi-host.
  • Remove audio-device from .vmx-file:
    • vi <path-to-vm>\VMname.vmx
    • Delete lines:
      • sound.autoDetect = "TRUE"

      • sound.virtualDev = "hdaudio"

      • sound.fileName = "-1"

      • sound.present = "TRUE"

      • sound.pciSlotNumber = "35"

  • Find the Vmid for the affected VM:
    • vim-cmd vmsvc/getallvms
  • Reload configuration for the VM:
    • vim-cmd vmsvc/reload <Vmid-of-VM>
  • Done!

Refresh your vCenter (or log out/in) and confirm that the device is now missing from the VM's settings.

Start the VM and confirm that everything is working properly.

I used following articles:

VMware Knowledge Base

VMware Knowledge Base

View solution in original post

0 Kudos
Highlighted
Contributor
Contributor

I recently ran into this issue.  Same scenario as the OP.  If you go directly to ESXi on the host with the offending VM, the "HD Audio" device is listed in the settings there (I can only confirm on ESXi 6.7u3).  All you have to do is power the VM off and remove the device as you would normally via the GUI.  As soon a I did this, I was able to migrate the machines I was having issues with normally.  I'm sure the marked solution does work, but this eliminates the headache of editing your vmx file manually.

I know the thread is pretty old at this point, but I wanted to put it here since it's the first search result I got when I started to research the issue.

Highlighted
Contributor
Contributor

Thanks man, definitely helped me out.

0 Kudos
Highlighted
Contributor
Contributor

Thanks, on 6.7u3, I was able to remove the HD audio by connecting to the web gui on host as you suggested. Just had to power down host, remove, and power it back on. 

  Did not work from Vcenter.  

0 Kudos
Highlighted
Contributor
Contributor

Worked well on a VM for 6.7u2. Just logged onto the host esxi (not vcenter) and removed the HD Audio via GUI.


Thanks for the hint.

0 Kudos
Highlighted
Contributor
Contributor

Worked like a champ, way better than the other way. Thanks!

0 Kudos
Highlighted
Contributor
Contributor

Go to the local host, not vCenter, shutdown the server in question, remove "HD Audio", power back up and migrate.

0 Kudos