Problem with Tools install in vSphere 7.0


since a few weeks i have the problem that i can't install or upgrade the VMware Tools. First i noticed this after installing a new Server 2022 test VM, but here i was thinking o.k. new unknown OS, so i installed the Tools manually.

But now after upgrading to vSphere 7.0 U2 i tryed to upgrade the tools of my 2019 VM's and got the same error.

In the vmware.log of the VM i found this:

ToolsISO: Error failed to verify signature using default cert: (null)
ToolsISO: Error signature check failed for Tools image map '/vmfs/volu[...]ls/isoimages_manifest.txt'.
ToolsISO: Updated cached value for imageName to '(null)'.
GuestOS: GuestOS_GetToolsImageName: Failed to get Tools ISO image path.
TOOLS INSTALL could not find tools for this guest OS.

and in the vpxa.log this:

message = "No VMware Tools package is available. The VMware Tools package is not available for this guest operating system. "
message = "vix error code = 21000"
msg = "The required VMware Tools ISO image does not exist or is inaccessible."

The files are accessable:

[root@vmsrv01:/vmfs/volumes/5f818f6b-5c6bde4c-f161-ac1f6bc586d4/locker/packages/vmtoolsRepo/vmtools] ll
total 214336
drwxr-xr-x 1 root root 73728 Jan 1 10:12 .
drwxr-xr-x 1 root root 73728 Jan 1 10:12 ..
-rw-r--r-- 1 root root 5642 Jan 1 10:12 isoimages_manifest.txt
-rw-r--r-- 1 root root 3215 Jan 1 10:12 isoimages_manifest.txt.sig
-rw-r--r-- 1 root root 58574848 Jan 1 10:12 linux.iso
-rw-r--r-- 1 root root 915744 Jan 1 10:12 linux.iso.sha
-rw-r--r-- 1 root root 3215 Jan 1 10:12 linux.iso.sig
-rw-r--r-- 1 root root 1989 Jan 1 10:12 linux_avr_manifest.txt
-rw-r--r-- 1 root root 3215 Jan 1 10:12 linux_avr_manifest.txt.sig
-rw-r--r-- 1 root root 156084224 Jan 1 10:12 windows.iso
-rw-r--r-- 1 root root 2439328 Jan 1 10:12 windows.iso.sha
-rw-r--r-- 1 root root 3215 Jan 1 10:12 windows.iso.sig
-rw-r--r-- 1 root root 1669 Jan 1 10:12 windows_avr_manifest.txt
-rw-r--r-- 1 root root 3215 Jan 1 10:12 windows_avr_manifest.txt.sig

The only thing i found is this: https://kb.vmware.com/s/article/78537

Has someone seen something like that? What can i doo?


0 Kudos
2 Replies

One thing i just tryed, i unpacked the tools file from the 7.0U2 ISO Image and replaced the files on the host with this files, but then i'm getting

TOOLS INSTALL updating Rpc handlers registration.
TOOLS INSTALL toolInstall.guestStoreEnabled=0
ToolsISO: Updated cached value for imageName to 'windows.iso'.
ToolsISO: Selected Tools ISO 'windows.iso' for 'windows2019srv-64' guest.
TOOLS INSTALL Attempting auto-upgrade (GuestStoreUpgrade=false).
TOOLS installed legacy version 11329, available legacy version 11333
TOOLS manifest update status is 9
TOOLS using cached value 0 for isoImageExists (refreshCount=1, lastCount=1).
TOOLS VMware ESX did not ship with the tools ISO.
TOOLS cannot be autoupgraded.
TOOLS INSTALL entering IDLE state.

So i was thinking, try to download the Upgrade bundle extract it and look if inside is a install pack for the tools. So i can try to uninstall and reinstall the tools.

But now i'm totally confused...

Inside the U2 upgrade bundle i found this vib:


But when i look on my Host i have this installed

tools-light VMware VMwareCertified 2021-01-01

when i look into the U1c upgrade bundle there are this tools:


So i was searching more...

I found that i tryed to install the december beta on a different host, here i imported the ISO into the LCM.

Is it possible that, because i imported the ISO to the LCM, the LCM upgraded the Tools on this host because he found a newer version in his repo?

0 Kudos

O.k. i removed the wrong tools and installed the correct one:

[root@vmsrv01:/tmp] esxcli software vib remove -n tools-light
Removal Result
Message: Operation finished successfully.
Reboot Required: false
VIBs Installed:
VIBs Removed: VMware_locker_tools-light_11.3.0.17249553-17356132
VIBs Skipped:
[root@vmsrv01:/tmp] esxcli software vib install -v /tmp/VMware_locker_tools-light_11.2.5.17337674-17630552.vib
Installation Result
Message: Operation finished successfully.
Reboot Required: false
VIBs Installed: VMware_locker_tools-light_11.2.5.17337674-17630552
VIBs Removed:
VIBs Skipped:

Now all works fine, so solved by my self. 😉

And what i have learned: Never import a beta iso to a vcenter where hosts attached which should not get beta parts. I havn't expected that parts of a imported iso will be used to patch other servers...

0 Kudos